0
$\begingroup$

Now in Blender Game Engine in 2.79, and previously in other components, I've frequently encountered situations where a seemingly closed container still lets other physics objects through. For example, in this model, I made a number of intersecting planes that are static physics objects. There are no gaps between the edges or at the corners. Indeed, with the overlap there is extra plane overhanging the edge of the box. I've also tried specifying collision bounds, including a larger margin. Nonetheless, other objects keep going right through the box.

Supposedly closed box that even has intersecting edges, yet object pass right through.

How can I make a closed container in Blender?

Thank you!

$\endgroup$
  • $\begingroup$ The problem most likely doesn't lie in the geometry itself I guess. The issue is probably in the simulation speed/precision and how computer physics are calculated. Very fast or very small objects may pass the collision detection. $\endgroup$ – Duarte Farrajota Ramos Jan 20 '18 at 21:49
  • $\begingroup$ I suspect you're right. I seem to encounter these issues with quite fast or small objects. Maybe these problems could also be prevented by adding more physics steps? $\endgroup$ – Eagle Gamma Jan 20 '18 at 21:57
  • $\begingroup$ Bullet (the physics engine) can't deal with small fast travelling objects very well. Unfortunately, it is a known issue. $\endgroup$ – Monster Jan 22 '18 at 7:13
  • $\begingroup$ Hehe, isn't a bullet a small fast traveling object? :) $\endgroup$ – Eagle Gamma Jan 22 '18 at 13:03
  • $\begingroup$ Hehe, isn't a bullet a small fast traveling object? :) $\endgroup$ – Eagle Gamma Jan 22 '18 at 13:03
0
$\begingroup$

Very fast or small objects seem to miss the collision detection. Keeping objects bigger and slower manages this issue.

$\endgroup$
0
$\begingroup$

At least in the Blender settings, you can increase the "Steps Per Second" rigid body world quality. That will make the physics engine to do the collisions more detailed. Rigid body world settings

I have not played with Blender game engine, so I don't know if this will take effect to it also or if there is some other similar setting to tweak.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.