4
$\begingroup$

I've put the MiraTools directory in the addons - nothing I can do will make it show in the addons ion user prefs. The *.py files are there, including init.py, but nogo. I can see all the other addons in that directory enabled & otherwise, vut not Mira_tools. Anyong got any ideas? I'm using Blender 2.78.

ok I am using the User Prefs, I've added addons before & they work. This one remains invisible.

I'm aware there are other addons in the pack. I have found the issue. I uninstalled V2.78, reinstalled it - still nogo. Then went to V2.79, still nogo. BUT on another machine using either 2.78 or 2.79, it works great. The issue is 32/64 bit OS (Windows) Mira works fine on my 32 bit machine. I have come across this before - there is still some bug between 32/64 bit directory listings (I'm sure it's an OS thing) where some files become invisible in that they won't "parse" but you can still see the listing in a dir. I've now seen this about 4 times, it screws me up once every two years, and it's still there. So - I appreciate your help, problem solved and - don't get caught!

$\endgroup$
  • $\begingroup$ have you reloaded blender after, or clicked the "refresh" button in the preferences/addon panel? I just tried with 2.76 and, apart a warning about using a version older than 2.78, I can find them and once activated, they load a toolbar tab with various tools... $\endgroup$ – m.ardito Jan 20 '18 at 19:20
  • $\begingroup$ @DuarteFarrajotaRamos there is something different about it, since the ZIP shipped by the creators contains more than just a Blender add-on. $\endgroup$ – dr. Sybren Jan 21 '18 at 10:52
2
$\begingroup$

From the information available on the Mira-Tools Wiki page:

Apparently the ZIP they ship contains all kinds of data, it's not just a Blender add-on. This means that you cannot install it via Blender itself, but have to do it manually. Their issue #22 also complains about this.

$\endgroup$
  • $\begingroup$ the wiki page says to copy "mira_tools" folder, not "mifth_tools"... I used that and it worked even on my 2.76b... $\endgroup$ – m.ardito Jan 22 '18 at 7:56
  • 1
    $\begingroup$ I had written mira tools. Someone, on correction, changed it $\endgroup$ – MCunha Jan 23 '18 at 17:32
0
$\begingroup$

I was having a problem, and found that all the tools are available in edit mode. I don't know if this helps anyone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.