1
$\begingroup$

I want to play a movie on a plane object in the Blender Game Engine. The movie works fine, however even if the background of the movie is transparent, when the movie is played it is shown as pitch black.

These are my settings:

GLSL (shading)

UV MAP

The UV map used as a screen is set to transparent (0 Alpha).

Material Tab

Set to SHADELESS and Transparency (0 Alpha)

Texture Tab

Use Alpha is checked! Influence/Diffuse: Color and Alpha are both checked and set to 1 (Default)

I normally use these settings for images and they work perfectly fine. However they don't seem to work with movies. Can anyone help?

The movie has been created with the Video Editor in Blender Cycles (2.79):

FFMpeg Video Container : Mpeg4 Codec: H264

The Film (Render) is set to Transparent.

The movie seems fine and it does show the alpha correctly.

Any idea of what I'm doing wrong? Thanks in advance

$\endgroup$
0
$\begingroup$

S O L V E D

The movie must have an alpha channel. This is how to obtain an alpha channel in a movie by using Blender Video Editor:

Properties(Output section):

File Format - FFmpeg video

Container - Quicktime

Codec - QT rle/QT ANIMATION

Once you are done, you will see that next to BW and RGB you now have RGBA. Your movie will be rendered with an alpha channel and in the game it will work perfectly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.