1
$\begingroup$

Edit: blender scene:

I have a simple scene with a lantern in it, the latern's bulb is a mesh with an emission shader. I of course light it from other angles as well, like from the side where I use a plane with an emission shader whose color is dictated by an image texture (so an image based light).

My problem is, no matter how weak the image based light is, even if it's so weak it's unnoticable in the scene, the effects of the mesh light basically eliminate. But as soon as I turn off the image based light, the mesh light wakes up again. This does not happen with light lights (e.g. area, spot etc) but those don't look the way I want them to look. Some proof:

wtf

though noisy, you see here that the lightPlane1.001 is active, but strength is 0.1. It's a blue-ish image, unnoticable in the scene. But even still, the mesh light is like secondary reflection only. On the contrary, when I turn off the image based light:

lol

You see that the mesh light immediately kicked in. They do not share the same material (though it wouldn't explain this either).

I'm using Cycles and I'm wtf-ed. Could someone help me? I'm not using any fancy group settings, everything is on the same layer.

EDIT: the node setups:

enter image description here enter image description here enter image description here

Edit again:

thick glass or no glass, the problem persists.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks for the tips, I go ahead and do it. Yes, a glass shader is in motion, the mesh has only one side. $\endgroup$ – agiro Jan 18 '18 at 21:56
  • $\begingroup$ does the glass have any thickness? $\endgroup$ – cegaton Jan 18 '18 at 21:57
  • $\begingroup$ Nope, only one sided glass. Updating the question right now $\endgroup$ – agiro Jan 18 '18 at 22:00
  • $\begingroup$ btw the link you sent was "not found" :/ $\endgroup$ – agiro Jan 18 '18 at 22:01
  • $\begingroup$ blender.stackexchange.com/a/57968/1853 $\endgroup$ – cegaton Jan 18 '18 at 22:06
1
$\begingroup$

Got it in the meantime. The solution was to turn off multiple importance sampling for the image based (mesh) light. The reason I didn't realize the render was noisy, not "not showing" is the use of CPU for preview (bc GPU incompatibility). Anyone having a slow or unsupported rig should consider waiting for some result.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.