1
$\begingroup$

So every time I try to run blender it starts to show the window, but then crashes.

I've tried uninstalling, reinstalling, purging (sudo apt-get purge blender). I've tried downloading from the Blender website and running that version (after unpacking). I've tried deleting the startup.blend and userpref.blend files. I've tried purging and deleting the blender install directory.

Blender was running fabulously last week, on Sunday I decided to to an

sudo apt-get upgrade

Now no blender worky. Me likes me my blender. Me needs help, please??

I was using v2.76 and I've tried v2.79 they both do the same thing.

Here's my OS info;

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ cat /etc/issue

Linux Mint 18.2 Sonya \n \l

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ cat /etc/linuxmint/info

RELEASE=18.2
CODENAME=sonya
EDITION="Cinnamon 64-bit"
DESCRIPTION="Linux Mint 18.2 Sonya"
DESKTOP=Gnome
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_sonya_cinnamon_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_sonya_cinnamon.php
USER_GUIDE_URL=help:linuxmint
GRUB_TITLE=Linux Mint 18.2 Cinnamon 64-bit

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ cat /etc/os-release

NAME="Linux Mint"
VERSION="18.2 (Sonya)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 18.2"
VERSION_ID="18.2"
HOME_URL="http://www.linuxmint.com/"
SUPPORT_URL="http://forums.linuxmint.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/linuxmint/"
VERSION_CODENAME=sonya
UBUNTU_CODENAME=xenial

Running blender from the command line gives me
drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ blender

connect failed: No such file or directory
Writing: /tmp/blender.crash.txt
Segmentation fault

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ cat /tmp/blender.crash.txt

# Blender 2.76 (sub 0), Commit date: 1970-01-01 00:00, Hash unknown

# backtrace
blender(BLI_system_backtrace+0x30) [0x1361b10]
blender() [0x97a98e]
/lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f1915a154b0]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5d7296) [0x7f18eaaf0296]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5d898e) [0x7f18eaaf198e]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5caae8) [0x7f18eaae3ae8]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x5cb9c5) [0x7f18eaae49c5]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x3e68f7) [0x7f18ea8ff8f7]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x3e71fd) [0x7f18ea9001fd]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x41d973) [0x7f18ea936973]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x16a07e) [0x7f18ea68307e]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x16fd93) [0x7f18ea688d93]
blender() [0x9801f7]
blender(wm_draw_update+0x882) [0x982092]
blender(WM_main+0x28) [0x97cfe8]
blender(main+0xef4) [0x95ce04]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f1915a00830]
blender(_start+0x29) [0x97a2b9]

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ blender --debug

Switching to fully guarded memory allocator.
Blender 2.76 (sub 0)
Build: 2016-02-06 01:10:10 Linux None
argv[0] = blender
argv[1] = --debug
connect failed: No such file or directory

Note: No (valid) '/home/drpeper/.config/blender/2.76/config/startup.blend' found, fall back to built-in default.

read file 
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
Writing: /tmp/blender.crash.txt
Segmentation fault

So I went to the apt logs to see what was changed on Sunday...

Log started: 2018-01-14  13:30:15 
(Reading database ... 252281 files and directories currently installed.) 
Preparing to unpack .../wine-stable_2.0.4~xenial_amd64.deb ... 
Unpacking wine-stable (2.0.4~xenial) over (2.0.3~xenial) ... 
Preparing to unpack .../wine-stable-amd64_2.0.4~xenial_amd64.deb ... 
Unpacking wine-stable-amd64 (2.0.4~xenial) over (2.0.3~xenial) ... 
Preparing to unpack .../wine-stable-i386_2.0.4~xenial_i386.deb ... 
Unpacking wine-stable-i386:i386 (2.0.4~xenial) over (2.0.3~xenial) ... 
Preparing to unpack .../libosmesa6_17.2.4-0ubuntu1~16.04.2_i386.deb ... 
De-configuring libosmesa6:amd64 (17.0.7-0ubuntu0.16.04.2) ... 
Unpacking libosmesa6:i386 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ... 
Preparing to unpack .../libosmesa6_17.2.4-0ubuntu1~16.04.2_amd64.deb ... 
Unpacking libosmesa6:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ... 
Preparing to unpack .../libgles2-mesa_17.2.4-0ubuntu1~16.04.2_amd64.deb ...
Unpacking libgles2-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Preparing to unpack .../libgl1-mesa-glx_17.2.4-0ubuntu1~16.04.2_i386.deb ...
De-configuring libgl1-mesa-glx:amd64 (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libgl1-mesa-glx:i386 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Preparing to unpack .../libgl1-mesa-glx_17.2.4-0ubuntu1~16.04.2_amd64.deb ...
Unpacking libgl1-mesa-glx:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Preparing to unpack .../libglapi-mesa_17.2.4-0ubuntu1~16.04.2_amd64.deb ...
De-configuring libglapi-mesa:i386 (17.0.7-0ubuntu0.16.04.2) ...
Unpacking libglapi-mesa:amd64 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Preparing to unpack .../libglapi-mesa_17.2.4-0ubuntu1~16.04.2_i386.deb ...
Unpacking libglapi-mesa:i386 (17.2.4-0ubuntu1~16.04.2) over (17.0.7-0ubuntu0.16.04.2) ...
Preparing to unpack .../google-chrome-stable_63.0.3239.132-1_amd64.deb ...
Unpacking google-chrome-stable (63.0.3239.132-1) over (63.0.3239.108-1) ...
Preparing to unpack .../libseccomp2_2.3.1-2.1ubuntu2~16.04.1_amd64.deb ...
Unpacking libseccomp2:amd64 (2.3.1-2.1ubuntu2~16.04.1) over (2.2.3-3ubuntu3) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libseccomp2:amd64 (2.3.1-2.1ubuntu2~16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...

The obvious thing seemed to be the mesa drivers being updated.  But uninstalling the current version and installing the previous version didn't change anything.  I've since updated mesa to version 17.2.8 (which seems to be the latest-ish) 

drpeper@Titaniumlicious-LM ~/.config/blender/2.76/config $ glxinfo | grep "OpenGL version"
OpenGL version string: 2.1 Mesa 17.2.8

Any help is appreciated!

$\endgroup$
  • 1
    $\begingroup$ have you tried the tar.bz2 version? $\endgroup$ – m.ardito Jan 18 '18 at 20:38
  • 1
    $\begingroup$ I never use repositories or ppas to install blender in linux Mint. It is usually outdated and might bring other problems. Just download the bz2 version from blender.org, unpack it in a folder in your home directory and run it from there. $\endgroup$ – cegaton Jan 18 '18 at 20:51
  • $\begingroup$ Thank you, I had already thought of that and tried it. I stated so in my question actually. $\endgroup$ – DrPeper Jan 18 '18 at 22:03
1
$\begingroup$

YESSS! I finally fixed it. So for just over a week now Blender would not load. It would pull up the initial window (blank) then crash. So after going through Blender withdrawals for a week I finally got desperate enough to try some radical solutions.

So the backstory is that after performing an update a week ago Sunday blender would crash during startup. After looking through the APT logs it appeared that Mesa might be the culprit. The update installed 17.2.x (i can't remember the exact version). I tried to downgrade but was unsuccessful. So I tried to upgrade to 17.2.8 (the latest in that series but it was unsuccessful as well). As part of the upgrade I had added the PPA

sudo add-apt-repository ppa:ubuntu-x-swat/updates sudo apt-get update

So first I backed that out with

sudo ppa-purge ppa:ubuntu-x-swat/updates

Which gives you a TONNE of warnings about "are you sure?", and "are you sure that you are sure????". But I was desperate so I said yes.

Then I upgraded the PPA to the 17.3.x line via;

sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update sudo apt-get upgrade

Again you get a bunch of warning about installing the PPA but i said "do it".

Without even rebooting I checked the MESA version with

glxinfo | grep "OpenGL version"

which reported;

OpenGL version string: 2.1 Mesa 17.3.3

So on a whim I tried running the blender v2.79 version which I had downloaded previously from the blender website (AKA the .tar.bz2). It didn't crash on startup and seems to be running fine. Then I tried the v2.76 version which I had installed previously from the official Ubuntu/Mint repositories and it worked fine too.

So an near as I can figure out when running mesa 17.2.x on a laptop with a "Mobile Intel® GM45 Express Chipset" processor on "Ubuntu 16.04/Mint 18.2 Sonya (Cinnamon)" seems to have been the culprit. Updating Mesa to the 17.3.x version worked for me.

I hope this helps any others out there.

$\endgroup$
  • $\begingroup$ I was also finding an issue withe the gpu driver from Nvidia, and had gotten it working again by regressing to the last driver. Linux Mint here. $\endgroup$ – Craig D Jones Jan 22 '18 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.