0
$\begingroup$

I've been trying to use shape keys to correct ugly armature deformation, but whenever I try to move a vertex in edit mode to where I want it to go it gives this super ugly curve thing.

enter image description here

enter image description here

Why are the edges curving like that? It's supposed to be straight! How to stop it from doing this? It's very frustrating, what's the correct way to make it bend like an arm?

$\endgroup$
  • $\begingroup$ Is Preserve Volume checked under the mesh's Armature Modifier? $\endgroup$ – Akados Jan 18 '18 at 19:02
  • $\begingroup$ No, but checking it didn't help. Not to worry though, I found the solution! I'm going to put the answer to it now. Thanks for trying to help! :) $\endgroup$ – Ariel Stacy Jan 18 '18 at 21:01
1
$\begingroup$

Okay! I found the answer!

enter image description here

The problem was that I had a subdivision surface modifier on the mesh but I didn't apply it yet. The armature was using the subdivision modifier to make it curve smoothly, but I was unable to edit those vertices that were making those weird curves because I didn't apply it to the mesh yet, all I was able to edit were the small amount of vertices that were there. So I applied the modifier to my mesh and now it doesn't curve anymore because I have control of those vertices in edit mode.

enter image description here

Unfortunately I had some shape keys to the mesh already and I had to delete them in order to apply the modifier. Oh well!

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ You would not have had to apply the subsurf modifier, if you had just moved it below the armature modifier. $\endgroup$ – Leander Jan 5 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.