0
$\begingroup$

enter image description here No matter what lamp I put in or how strong I make them the shadows on this file don't seem to be affected at all?

I've tried changing the shadow settings but nothing really seems to be working. If I move any lamps the shadows on the model stay static in that they're completely unchanging and don't move in response to the changing of the lamp tool.

It's almost as if the shadows themselves are painting onto the model but even if I strip the material the shadows are present on the model itself and are still unaffected by any change in lighting.

enter image description here

Absolutely no difference in shading despite repositioning on lamp.

I'll post the file as an example so whoever's curious can take a peek. Here's the file

$\endgroup$
  • 3
    $\begingroup$ Please don't just post the file and expect an answer without a more detailed explanation of what is happening. Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information. Add images of the issue and your settings. $\endgroup$ – cegaton Jan 17 '18 at 5:29
  • $\begingroup$ There you go. Added more information. $\endgroup$ – TwistyReptile Jan 17 '18 at 5:58
  • 2
    $\begingroup$ Are you relying on viewport preview to see lamp efects? You do realize that those are only visible upon rendering, right? Cyles lamps have no effect on OpenGL viewport rendering. $\endgroup$ – Duarte Farrajota Ramos Jan 17 '18 at 6:13
  • $\begingroup$ Cycle lamps? I'm pretty sure these are just regular lamps. I've tried to reproduce the same problem on another blender file and there's been no luck. This file's shadows are bugged. $\endgroup$ – TwistyReptile Jan 17 '18 at 6:18
  • $\begingroup$ Are you using Internal or Cycles engine? $\endgroup$ – Rogue Lotus 4 Jan 17 '18 at 7:00
3
$\begingroup$

You switched Maximum draw type to Solid. Set this back to Textured

enter image description here

And also note, that this type of lamps must be rotated, to see the effects.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.