1
$\begingroup$

This question already has an answer here:

OLD TITLE: Smooth mesh to hide the low poly subdivisions

Title of the question changed, as the main issue seems to be that with the triangulate modifier and the subdivision modifier, there are new faces and vertices being created.

New question:

Using the Bevel Modifier, Triangulate Modifier, and the Subdivision Modifier, new vertices are being formed as you can see in the second image. I would like it to look like the first image, except with the Subdivision Surface modifier working, so the cutout loos smooth.

Beveling with no Limit only shows these two problems:

enter image description here

New Blend File:


Old question:

I created a cutout of a cylinder in my mesh. I beveled it, and it gives me this:

enter image description here

I would like to 'smooth' the edges to look like a nice curve, and not blocky.

I used a Subdivision Surface modifier, but: enter image description here

I already tried going around using Ctrl + T, but I could not get rid of them all, and it made my mesh look messy.

Is there a better way for me to subdivide it without the vertices going nuts?

EDIT:

R.M's method below works up to an extent. It curves the cutout, but the face deforms appear still. Is this more of an issue with my mesh?

enter image description here

With no Bevel Limit, the corners are sharp at the front of the mesh, but the bottom still has the corners warping in. With the Angle, it makes the mesh more round/smoother, how I want it, but the bottom still has the mesh warps. As well as the front corners.

$\endgroup$

marked as duplicate by cegaton, Community Jan 18 '18 at 4:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    $\begingroup$ This is caused by n-gons for sure. Try to use only quad faces. $\endgroup$ – m.ardito Jan 15 '18 at 22:15
  • $\begingroup$ I tried, such as removing that line at the bottom, but it would only go away if the faces around it went with it. $\endgroup$ – Akados Jan 15 '18 at 22:19
  • $\begingroup$ I don't see warping with no limit. The only problem I'm noticing is that the round parts are not smooth, but you may have to go back to change this (use cylinders with more detail). $\endgroup$ – R.M Jan 16 '18 at 0:14
  • $\begingroup$ It's at the bottom for me. Three corners bevel inwards. Also, around the mesh, it appears that two faces are in the same location at some places, creating a dark shading in a few places near corners. $\endgroup$ – Akados Jan 16 '18 at 0:17
  • $\begingroup$ I think I see where the confusion is coming from: the order of the modifiers! Check the .blend file I linked: triangulate first, then bevel, then subdivide. $\endgroup$ – R.M Jan 16 '18 at 0:19
2
$\begingroup$

If you don't want to triangulate the faces manually, you can use the triangulate modifier. Then, add a bevel modifier, and a subdivision surface modifier:

Modifiers

This gives the following result:

model

Be sure to triangulate before subdividing!

I'm noticing that some of the circles are still "blocky". To fix this, try to go back, before you beveled it, and use a bevel modifier (not to be confused with the one above), setting a limit on the angle. Example:

No limit:

no limit

With limit (note that the less pointy edges were not affected, and will be smoothed out by a subdivision surface modifier): with limit

$\endgroup$
  • $\begingroup$ Yeah, the bottom has a curved new face appearing still. I'll try the bevel modifier. $\endgroup$ – Akados Jan 15 '18 at 23:08
  • $\begingroup$ Yeah, the bottom has a curved new face appearing still. I'll try the bevel modifier. It smooths it out, but the odd faces keep appearing at the bottom, and at the front foot corner. See here $\endgroup$ – Akados Jan 15 '18 at 23:13
  • $\begingroup$ @Akados ah, I see that problem too, now. You can use a bevel modifier between the other two to fix that problem. I'll update my answer. $\endgroup$ – R.M Jan 15 '18 at 23:21
  • $\begingroup$ Did what you said, but I still get the problem. I updated my question if that helps. $\endgroup$ – Akados Jan 16 '18 at 0:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.