11
$\begingroup$

What could cause this? f12:

F12 Render

Viewport:

Viewport

(the f12 has fewer samples, but even when the viewport is at lower samples it looks different..)

I know about color management, but that is at the defaults..

Colo Management

EDIT: oops.. I know 'log' is not a default, but that is because I was fiddling with it. The image above is rendered with 'default'

The material is quite simple, only a translucent shader. (for testing) I even tried appending everything into a new file to reset all the settings, but no difference.

EDIT2: Uploaded blend http://www.pasteall.org/blend/22200

$\endgroup$
  • $\begingroup$ if you wish to share the blend, or a sufficiently small portion of it so that the effect is still visible, I'd like to have a look. $\endgroup$ – zeffii Jun 13 '13 at 8:53
  • $\begingroup$ You should post your render settings, preferably Sampling, Light Paths, Performance and maybe even Film. $\endgroup$ – klesus Jun 13 '13 at 9:40
  • $\begingroup$ I currently don't have access to the blend, but when i get it I'll upload it. though I don't think that would escape appending into a new file? $\endgroup$ – gandalf3 Jun 14 '13 at 3:07
  • $\begingroup$ You might have changed some light path settings. $\endgroup$ – Daniel Pendergast Jun 14 '13 at 12:39
  • 1
    $\begingroup$ GPU vs CPU? Compatible vs Experimental mode? Color Management? Film emulation? Without a new file, it's hard to say. $\endgroup$ – Mike Pan Jun 15 '13 at 3:09
18
$\begingroup$

The flower mesh has a solidify modifier which is only enabled for rendering. The extra thickness from this modifier makes the translucent material give a different result.

In general for differences between render and viewport, check these:

  • Object viewport and render visibility in the outliner
  • Modifier viewport and render visibility
  • Particles and hair resolution settings
  • Curve, surface and metaball tessellation settings
  • Render layer settings
  • Color management settings
  • Compositing nodes and sequencer strips
$\endgroup$
  • 3
    $\begingroup$ Thanks! I can't believe I missed that.. I was searching for almost a day :P $\endgroup$ – gandalf3 Jun 19 '13 at 23:49
  • $\begingroup$ This is a good reference post. $\endgroup$ – wchargin Aug 21 '13 at 1:25
1
$\begingroup$

Looks to me like you have extra lights that are hidden in the viewport, so they're not being rendered in the viewport. However they will still render with F12, unless they are disabled at render time.

Check in the Outliner to see if you have objects that are hidden in the viewport.

enter image description here

$\endgroup$
  • $\begingroup$ I thought of that, and checked them all thoroughly.. unless I missed one, it's not that. (also check to see if it was the other way around, hidden in render, but no..) $\endgroup$ – gandalf3 Jun 18 '13 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.