0
$\begingroup$

I'm not sure how I can clearly explain this as a noob, but how do I make an image node in texture editor not repeat its texture when it is outside of the UV map. The first image below is what I want it to look like, the bottom is what happens when I use the node editor.

This is what I want it to look. Note that the texture doesn't repeat when it goes outside of the UV map

This is what happens when I use the node editor for the texture.

$\endgroup$
1
$\begingroup$

Scroll down your material panel to Image Mapping and change Extension from Repeat to Clip

enter image description here

$\endgroup$
  • $\begingroup$ Those controls are entirely absent when I use nodes for the texture. $\endgroup$ – ringkun mori Jan 13 '18 at 6:11
  • 1
    $\begingroup$ If all you have is an image going to an output, i would just uncheck the Use Nodes, as it's not needed unless you are going to add more nodes later $\endgroup$ – LaserMan Jan 13 '18 at 6:30
  • 1
    $\begingroup$ Or add more space around your image in an image editor so it won't repeat as frequently $\endgroup$ – LaserMan Jan 13 '18 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.