2
$\begingroup$

I've got a problem where some particles of my hair particle system go underneath certain faces.

  • The normals of those faces are faced correctly and the same way as all other faces.
  • Vertex paint is relatively smooth and does not have random faces not selected.
  • Changing the seed number does not make the problem go away/change to different faces.

Image description:

1 Showing (poorly drawn) faces with missing particles

2 Wireframe of image 1, showing me that there are indeed instances of the particle system there, just underneath the surface

3 Render of image 1

4 Shaded mode of different part of the image with the same issue, faces with the problem are indicated by green arrows

5 Vertex weight paint of the same part of the image as 4

1 Showing (poorly drawn) faces with missing faces 2 Wireframe of image 1, showing me that there are indeed instances of the particle system there, just underneath the surface 3 Render of image 1 4 Shaded mode of different part of the image with the same issue, faces with the problem are indicated by green arrows 5 Vertex weight paint of the same part of the image as 4

$\endgroup$
  • $\begingroup$ Yes, as stated before, all normals are faced correctly (up). Cant seem to upload my simplified version since it exceeds 30 mebibytes, even though nothing is packed into the file. $\endgroup$ – Lander Jan 12 '18 at 22:10
  • $\begingroup$ Large file size is probably due to cached animation of particle system or something else. There is Free Bake button in the Cache rollout in particle settings, see also blender.stackexchange.com/questions/2/… $\endgroup$ – Mr Zak Jan 12 '18 at 22:18
  • $\begingroup$ I believe that function is only for the emitter particle system, I am using a hair system. $\endgroup$ – Lander Jan 13 '18 at 9:33
  • $\begingroup$ If Hair Dynamics in particle system is unchecked (I see it is) then yes. Anyway particle system itself shouldn't weigh that much. Are there any other highpoly objects you could remove from test file? As to particle system results - do you use any other modifiers on the object with particle system? Try to reproduce the problem on simple case. Try also checkiing Even Distribution in particle system settings $\endgroup$ – Mr Zak Jan 13 '18 at 10:14
  • $\begingroup$ Nope, no other modifiers. I now added a subdiv modifier though to see how it reacts to more geometry (tried decimating it, didn't work) and that appears to have worked. Not an ultimate solution, especially since I have already quite a lot of geometry in my scene, but it does the job. I still would love to figure out what is causing this though. I'll post a link to the simplified version once my google drive has finished syncing. (Probably tomorrow) $\endgroup$ – Lander Jan 13 '18 at 20:08
1
$\begingroup$

Added a subdivision modifier to change the geometry of the surface on which the particles are being placed on (not the particle itself), which fixed the issue. Not ideal, but it works.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.