9
$\begingroup$

I have a scene with a particle system, which emits a few planes, to which is assign a cloth simulation. A wind point force emitter drives the particles in a swirl. Cool.

enter image description here

The overall action is getting to be what I want with the settings shown or in the file attached.

What I would like, however, is for the speed of motion of the particles to move at something less than the speed they do now... say 15% of present. The amount of vertical offset from the force would be the same, the same swirliness.... just slower... Like if I remapped time for the scene. Since there are other things going on in the scene, I cannot really remap, however.... so I just need to control fairly precisely the speed with which the particles move.

All input welcome.

UPDATE: The solution I accepted below seems to nearly work, or I am understanding it poorly. Here's the jerky motion I am getting... usually, anyway.

enter image description here

$\endgroup$
  • $\begingroup$ Try to export it to cache (alembic or another) and do time remap. Usually, there is an option to bake cache within frame range, so you can test it on couple of seconds to make sure it works and don't waste time on exporting full length motion. $\endgroup$ – Serge L Jan 15 '18 at 23:12
  • $\begingroup$ This just has to do with your various caches, I think. I created new caches for the cloth sim and for the particle system, then deleted the prior caches, then baked everything, and the jitter went away. For the particle cache I set "Cache Step" to 1, it was previously at 10 and that may have contributed to the issue. $\endgroup$ – risingfall Jan 16 '18 at 22:32
6
+100
$\begingroup$

Final:

Final

Overview:

This is pretty easy solution surprisingly. Only thing you need to do is keyframing Cloth > Speed > Multiplier value.

Slow down speed is exaggerated in this example just to be more visible. For slowing down by 15% use values 0.75 instead of 0.1.

Steps:

  1. Set frame to 1 and press I hovering mouse cursor over Multiplier value 1 to set keyframe.
  2. Select next frame which should be starting point for slow down, change Multiplier to something like 0.1 (smaller value, slower time) and set keyframe.
  3. Select frame which should be start of the end of slow down and set another 0.1 Multiplier keyframe.
  4. Lastly set a keyframe which will be definite end of the slow down with Multiplier value 1.

If you want so more help, please put it in the comments as I really don't know what else to explain, it's really simple setup.

steps

Edit:

As @risingfall stated in his comment, you will need to add new cache to Particles and set Cache step to 1, than remove previous one and do the same with Cloth (without changing step, as it isn't present).

cache

Edit 2:

It seems that doing this only with Cloth cache is enough. Even in my gif under final you can see that on the timeline sim is baked only at certain frames. Adding and deleting cache for Cloth is fixing this. To be sure, re-add both caches.

I don't know why this is happening, I'm gonna investigate it further, but at a first glance it seems to be bug/corrupted cache.

$\endgroup$
  • $\begingroup$ I did this, and it appears to do exactly as intended. One note: When I created the .1 keyframes and baked all, I initially got a playback in the viewport that was "springy".... The cloth pieces seemed to bounce without moving accurately. I changed the multiplier value manually to a larger number, but did not keyframe it, then played the animation again.... and all was as intended. $\endgroup$ – rcgauer Jan 16 '18 at 21:15
  • $\begingroup$ See addition above: Trouble getting smooth playback, although it worked once, I thought.... $\endgroup$ – rcgauer Jan 16 '18 at 21:21
  • $\begingroup$ @rcgauer check my edit. $\endgroup$ – cgslav Jan 17 '18 at 0:31
  • $\begingroup$ For folks who follow on later, all of Luke;s input was on target... but to sum up the last part: Delete existing caches if you see the jumpiness... I cannot account for it, and it is repeatable (sometimes).... but clearing caches very deliberately fixed it for me... And it did seem to be specific to the cloth sim: Hiding the cloth sim resulted in smooth replay even with the initial cache... $\endgroup$ – rcgauer Jan 17 '18 at 19:37
  • $\begingroup$ @rcgauer I've tried to reproduce this error in couple of different scenarios and it seems that it's strongly related to Particle Instance modifer. If you make clean Cloth sim with "Time remapping" everything is ok. So it's most likely that Particle Cache is breaking Cloth cache trough Particle Instance modifier. After all, Particles System in Blender is a lot more buggier than this issue... $\endgroup$ – cgslav Jan 17 '18 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.