0
$\begingroup$

An image worths more than 1000 words. enter image description here

The water seems to be reflecting mostly the colour of the background but not too much the lights.

Basically, i'm trying to do this:

enter image description here

But i don't know what's happening. I stopped doing the tutorial because of this, tried a lot of things with the material imput, but nothing has changed.

(I'm doing this tuto, btw) https://www.blenderguru.com/tutorials/create-a-realistic-fruit-splash

So... what i' doing wrong?

EDIT: Did it again with a mesh in the background (inside a cube). Not solving my problem at all :/

enter image description here

Still looks like some kind of onyx material, but nothing at all like water.

$\endgroup$
  • $\begingroup$ Related blender.stackexchange.com/questions/15683/… $\endgroup$ – Duarte Farrajota Ramos Jan 11 '18 at 11:30
  • $\begingroup$ But isn't supposed to be that way. I used to do that kind of stuff, working with fluid simulation and stuff, and the water was "visible" with every background, now it looks like some kind of weird mirror that is almost everything black. $\endgroup$ – J. J. Jan 11 '18 at 12:33
  • $\begingroup$ Please post your render settings or the blend file. $\endgroup$ – AdamTM Jan 12 '18 at 9:10
  • $\begingroup$ I haven't looked at the tutorial, so I can't say for sure what's going on. Nor can I find any attempts at a water material in your .blend. Two things come to mind though. 1. The shader isn't everything. The lighting is just as important, and with all black environment, you may have a really hard time getting anything to look the way you want. 2. Less important, but not irrelevant, The Glossy BSDF has a default IOR of 1.45. This is some kind of compromise-catch-all setting. For proper pure water set it to 1.33. $\endgroup$ – Duane Dibbley Jan 13 '18 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.