1
$\begingroup$

So I have been following the Blender Guru modeling tutorial with minor changes every thing looked OK till he added the sub-surf modifier and I have no idea how to fix (followed tutorial https://www.youtube.com/watch?v=WxMwa0njGSM )

this is my edit view with and with out sub surf enter image description here

enter image description here

and this is how it should look likeenter image description here

$\endgroup$
0
6
$\begingroup$

I guess your mesh has something different in the bottom: I think you have a single bottom face (N-gon), which is causing this issue...

if you have this (sorry for the horrible mesh, I'm before breakfast...)

enter image description here

subsurf behaves well

enter image description here

while if you have a single N-gon face

enter image description here

subsurf behaves like in your model

enter image description here

if unsure, share your model through

http://blend-exchange.giantcowfilms.com/

then edit your question and post the provided link...

edit: after getting your file I found that this model has (still) several issues: at the base there are still n-gons, ruining the subsurf effect, but overall it has some other modeling issues... giving aso bad mirroring results.

About the ngons, this what you have one side

enter image description here

and the opposite is even worse

enter image description here

then below you have some faces with inverted normals

enter image description here

then again, its quite irregular on lines that are supposed to be quite linear instead: this ruins both mirror and subsurf

eg: here

enter image description here

enter image description here

enter image description here

enter image description here

Nothing terrible, and it can be corrected, but I suggest you to try to model keeping an eye on such things, because it helps you model better, and get better results. First, I recalculated normals (select all in edit mode, then CTRLN)

Then I tried to remove those ngons, getting something like this

enter image description here

if you enable subsurf now, it looks better, but not at its best:

enter image description here

it lacks some subdivision at the base, eg:

enter image description here

with this further subdivision,

enter image description here

the base becomes more defined when you subsurf later

enter image description here

Here is the file a bit corrected (imho, it could still be improved)

Hth, Marco

$\endgroup$
8
  • 1
    $\begingroup$ To add to this, use the knife tool to get rid of the N-gon by adding the needed edges. $\endgroup$
    – Tim
    Jan 7 '18 at 13:56
  • $\begingroup$ yeah I think that is the problem i will give it a shot and come back at ya $\endgroup$
    – CatMann
    Jan 7 '18 at 22:04
  • $\begingroup$ Ok so I did that and still came out weird i have no idea what to do $\endgroup$
    – CatMann
    Jan 7 '18 at 23:08
  • $\begingroup$ As said above, share your model. $\endgroup$
    – m.ardito
    Jan 7 '18 at 23:24
  • $\begingroup$ I already did that. $\endgroup$
    – CatMann
    Jan 9 '18 at 6:57
0
$\begingroup$

You model has faces on the bottom but his doesn't, that is your main problem. Where you have the crease about halfway up is caused by faces inside your model. Go to face select mode, and in wireframe view you can easily select and delete the extra faces.

$\endgroup$
1
  • $\begingroup$ well it looks good when i remove the bottom face but i don't remember him removing it so i don't really know what to do now since the anvil has no bottom $\endgroup$
    – CatMann
    Jan 7 '18 at 6:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.