-1
$\begingroup$

This is my first question/post on Blender Stack Exchange, please forgive mistakes.

I recently run the Blender BMW GPU Benchmark in Blender 2.79.

My PC specs are:

  • 64gb of DDR4 Ram
  • i7-8700k
  • GTX-1080

The scene took more than 3 minutes to render, however other people around the internet report a render time of 1 minute or less for the exact same scene on the same graphics card.

I searched the whole internet for a reason or solution for the long render time, didn't find anything though.

Maybe someone here can help me. Any help is appreciated ;)

EDIT:

First, i used the 'wrong' benchmark file (1250 samples instead of 400 samples), thanks @itafan.

However even with the 400 samples file, my rendertime is lower than average. I now run the benchmark on several configurations: Windows 10 / Ubuntu 17.10, Blender 2.79 / newest exp built, enabled Intel Turbo Boost / Disabled Intel Turbo Boost, Monitor connected to gpu / igpu.

  • Win10 /Blender 2.79/enabled Turbo Boost /gpu : 1:35 min
  • Win10 /Blender 2.79/disabled Turbo Boost/gpu : 1:04 min
  • Win10 /Blender 2.79/enabled Turbo Boost /igpu : 1:28 min
  • Win10 /Blender 2.79/disabled Turbo Boost/igpu : 0:59 min
  • Win10 /Blender exp /enabled Turbo Boost /gpu : 1:32 min
  • Win10 /Blender exp /disabled Turbo Boost/gpu : 0:55 min
  • Win10 /Blender exp /enabled Turbo Boost /igpu : 1:16 min
  • Win10 /Blender exp /disabled Turbo Boost/igpu : 0:42 min
  • Ubuntu/Blender 2.79/enabled Turbo Boost /gpu : 1:35 min
  • Ubuntu/Blender 2.79/disabled Turbo Boost/gpu : 1:04 min
  • Ubuntu/Blender 2.79/enabled Turbo Boost /igpu : 1:28 min
  • Ubuntu/Blender 2.79/disabled Turbo Boost/igpu : 0:59 min
  • Ubuntu/Blender exp /enabled Turbo Boost /gpu : 1:32 min
  • Ubuntu/Blender exp /disabled Turbo Boost/gpu : 0:55 min
  • Ubuntu/Blender exp /enabled Turbo Boost /igpu : 1:16 min
  • Ubuntu/Blender exp /disabled Turbo Boost/igpu : 0:34 min

As we can see, enabled Intel Turbo Boost seems to be affecting performance drastically, however, i have no clue why. Connecting the Monitor to the igpu also improves performance, but this should be clear. Note that on every test setup, Blender and the required hardware drivers were the only things installed on the OS.

$\endgroup$
  • $\begingroup$ Related blender.stackexchange.com/questions/76149/… Also make sure you actually enabled GPU rendering $\endgroup$ – Duarte Farrajota Ramos Jan 6 '18 at 23:23
  • $\begingroup$ I did, triple checked that. Cpu Rendering is actually faster for some reason. $\endgroup$ – lulle Jan 6 '18 at 23:48
  • $\begingroup$ What tile size are you using? $\endgroup$ – Brenticus Jan 7 '18 at 1:15
  • $\begingroup$ The tile size configured in the test files, 32x32 for cpu render, 256x256 for gpu render. $\endgroup$ – lulle Jan 7 '18 at 8:42
1
$\begingroup$

Probably you're running the wrong file, it's not your fault, the results are related to a scene with 400 samples, while you're probably running the one with 1225 samples from the official website. You can find the right file here:

https://blenderartists.org/forum/showthread.php?239480-2-7x-Cycles-benchmark-(Updated-BMW)

you can also try to run this:

https://blenderartists.org/forum/showthread.php?439394-The-new-Cycles-GPU-2-79-Benchmark

Good luck.

$\endgroup$
  • $\begingroup$ Thanks a lot, i guess that was the problem. However even with the 400 samples file, my gpu render time is below average (~1:18 minutes). Might be a driver problem or something on my machine. $\endgroup$ – lulle Jan 7 '18 at 9:45
  • $\begingroup$ I tried to render with Blender 2.8 and it turned out, it renders the scene within 20 seconds $\endgroup$ – lulle Jan 7 '18 at 14:51
  • $\begingroup$ I think 2.8 has some cycles effect disabled, try last 2.79 exp build you should have a result of 35-40sec. $\endgroup$ – itafan Jan 7 '18 at 15:26
  • $\begingroup$ I just tried the most recent two 2.79 experimental builds, both gave me a render time of 1:15 minutes (with the 400 samples file). I'll reinstall Windows 10 on my machine and try again. $\endgroup$ – lulle Jan 7 '18 at 20:44
  • $\begingroup$ This is strange, you have tried others not Blender GPU Benchmark? Or a clear and standalone Blender installation? Maybe you have touched something in the user preference. I get 1:10 with 2.79, and 00:54 (GPU) 00:47 (CPU+GPU) with last 2.79 exp build, and my pc is at least 30% less powerful than yours, (970G1+i5-4690k). $\endgroup$ – itafan Jan 7 '18 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.