1
$\begingroup$

I am a bit of newbie, and trying to install blender on Red Hat. I am using RHEL 6.9 and constrained to use glibc v2.12. I know this is not the latest version but I know that library is not compatible with the latest download of "blender". Anyone know of an older version in an blender archive that is compatible with glibc v2.12?

$\endgroup$
1
$\begingroup$

By only looking at the filenames, v2.78 has releases for glibc 211 and 219.

Another option would be compiling blender yourself, that will allow you to patch any glibc calls that aren't compatible with the older library version. As it is only the latest version that doesn't use the older library, I'd expect it to be only a matter of linking it with the older library rather than making any code changes. Any incompatible code changes that have been made can be found in blenders source code repository so you can also see any related code changes that will be affected by the change.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.