0
$\begingroup$

Was retopologizing a dress when suddenly I was no longer able to zoom (in nor out) or pan the camera. I can only rotate the camera.

I closed Blender and restarted it, loading my project from a save point BEFORE this started happening and the camera controls are still messed up, only allowing me to rotate.

I tried changing the input shortcuts, and that didn't help either.

It's not a case of being zoomed too far in or out, I can still see the dress, at a normal distance I'm usually at, just a case of zooming & panning suddenly not working.

Anyway, I then loaded an even earlier save, I was then able to pan & zoom, but rotating no longer worked. Then when I zoomed in closer to the dress, the ability to zoom & pan stopped working again (I still wasn't really close to it though, could still see most of the top of the dress)

Anyway, when I start a new, blank file, everything works fine. Can zoom, pan & rotate like normal (and yes, zoom much further in than I was when it stopped working)

So, I'm at a complete loss as to what happened. I would ask if I should reinstall Blender, but it works fine in a new, fresh file. What did I do in my project that is messing it up.

Edit: The issue seems to be due to Surface Deform. When I choose that modifier and bind it to another layer and then apply it, then while in Object Mode the camera locks up if I zoom even remotely close to the dress. However, the camera still works normally if I'm in Edit Mode, which may be by design, but seems like something that may want to be looked into.

$\endgroup$
1
$\begingroup$

Just had the exact thing happen to me and fixed it in last ditch effort. Phew

Can't re-trace my steps exactly to emulate the problem, however the fix is still fresh. Screen Split 3D viewport in two, in the new viewport I hit numpad 0 and from there navigating the virtual cam - Shift pan and Ctrl zoom - seemed to return the initial viewport back to functioning as it should.

Would love to know how that happened in the first place. Did I accidentally hit a slider or dropdown? Or is this a bug?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.