1
$\begingroup$

I was working on a scene with a cylinder shaped object. It was freely movable and rotatable using Transform pane, but suddenly I couldn't move it using the Transform pane. It is now just movable and rotatable using shortcuts like G and R. And when I use shortcuts, the values in the Transform pane change. Please refer the attached video and blender file.

video

I need your help!

$\endgroup$
4
$\begingroup$

I found the reason. This could be a silly Q&A, but I think someone could do a similar mistake. I was trying to move the object (where it has 'rigid body' physics) in the middle of an animation. Set the frame number to the first frame and then adjusting the transform solved the problem.

I accidentally found this while suspecting all the possible causes. When I removed 'rigid body' physics from the object, it worked as I intended. That was because it is not affected by rigid body animation anymore and therefore free from frame numbers.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.