0
$\begingroup$

I imported this model from MakeHuman, by exporting it as a dae and importing it into blender. This worked great, however there is one "glaring" (pardon the pun) problem. The model's eyes don't have any texture, as can be seen here:No eye texture

However, if I remove the eyes from the head and look inside them on the other side of the object, there's the texture! Eye texture inside

I've tried flipping normals (by hitting space and typing flip normal and hitting enter) and recalculating them (by following the instructions here: How to recalculate normals?).

Neither of these results in the eye textures being on the proper side. It looks proper in MakeHuman

$\endgroup$
1
  • $\begingroup$ The solution is to make sure that the texture specular color is ticked. $\endgroup$
    – Snake123
    Mar 8 '18 at 20:19
1
$\begingroup$

If you look closely, you will see two layers in the eye. The exported MakeHuman model contains the cornea of the eye as well (the clear layer that covers the eye). In the viewport this appears white, but when rendering it should appear mostly transparent.

$\endgroup$
3
  • $\begingroup$ It does not appear properly in rendered mode either $\endgroup$
    – lightbord
    Jan 3 '18 at 3:28
  • $\begingroup$ It could be that the cornea material did not get exported. I haven't worked with MakeHuman in a long while. You can either add a material to the cornea or just remove it. $\endgroup$
    – Brenticus
    Jan 3 '18 at 3:39
  • $\begingroup$ @lightbord Do not rely blindly on Imported Materials $\endgroup$ Jan 3 '18 at 4:05
0
$\begingroup$

The fix in blender 2.9 is to select the eyeballs in object mode, select material properties, expand settings and on blend mode select 'Alpha Blend'.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.