2
$\begingroup$

I am creating an old greek pillar for practice but during the creation process there appears to be a seam thats being rendered in the texture and model, I have gone in to texture paint mode and tried using the clone, and smear tool to blend the textures, and while it will blend the actual texture together it does absolutely nothing to the seam, I have also tried baking uvmap. Does anyone know what could be causing this problem? Did I incorrectly unwrap the model? I have surfed the threads trying to find something to help me fix my issue but it seams everything I try does nothing to make this seam disappear.

Image Cycles_Render

UVMAP

Node Editor Screenshot

EDIT:

I have turned the bias down to zero, it yields a slightly better result but the seam is still visible. Should I be using an image editor to make the texture tile properly?enter image description here

$\endgroup$
  • $\begingroup$ I had a similar issue, and my solution was turning the bias to 0 before you bake the normal map. $\endgroup$ – Akados Jan 1 '18 at 17:39
  • $\begingroup$ @Akados I am still learning, is the bias option in the node editor, uv editor, mesh tab, render tab? I have not been able to find that option. $\endgroup$ – Myles Jan 1 '18 at 18:00
  • $\begingroup$ It's in the Render Properties, under the Bake settings. (Blender Render, then after the bake, switch back to Cycles if you're using Cycles) $\endgroup$ – Akados Jan 1 '18 at 19:33
  • $\begingroup$ -Make sure the left and right side of your texture map match. -Run "Remove Doubles" on you mesh. -Post your texture map here $\endgroup$ – Othoap Proto Jan 1 '18 at 21:23
  • 2
    $\begingroup$ The issue is not with the UVs or the seams. Your texture needs to be tileable or seamless. Read: blender.stackexchange.com/questions/15085/… and blender.stackexchange.com/questions/71636/… $\endgroup$ – cegaton Jan 2 '18 at 0:22
0
$\begingroup$

Make sure to leave some space (a few pixels at least) between your UV pieces. Then turn on bleed in texture paint mode and when you bake things, so your texture extends beyond the boundaries of your model's UV coordinates. Doing both these things will avoid interpolation issues at the seams. There may be more issues in your case, but this is the first thing I would do to get rid of the seams.

*Bleed for texture painting is located in the Tool shelf > Options > Project Paint > Bleed. Increase the value to say 8. For baking, the same thing is called Margin. But again, for either of these to be effective, you must first add some space between your UV pieces.

$\endgroup$
  • $\begingroup$ Thank you for helping, I have been unable to find the "bleed" option in texture paint mode, can you be a bit more specific as to where it is located? A simple google search is not turning up the specific information I am looking for. $\endgroup$ – Myles Jan 3 '18 at 0:02
  • $\begingroup$ I've extended my answer a bit ;) $\endgroup$ – HENDRIX Jan 3 '18 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.