1
$\begingroup$

When I switch back to Object Mode from Edit Mode, the displayed model still looks the same as it was before I changed the polygons (Texture, Rendered and Solid view, makes no difference):

Example

enter image description here

Is there anything to force refresh? it works just fine when I edit with Sculpt Mode instead, but I needed to remove some vertex in this part.

$\endgroup$
  • $\begingroup$ Blender doesn't need any special action to refresh, changes should be applied immediately without explicit intervention. What were you expecting to see that didn't update? $\endgroup$ – Duarte Farrajota Ramos Dec 29 '17 at 11:22
  • $\begingroup$ @DuarteFarrajotaRamos see how the model in the circled part looks different? that's what I'm trying to understand, as you say it should refresh automatically but for some reason it's not happening, it's like the changes I did in Edit Mode never happened. $\endgroup$ – Amaya Dec 29 '17 at 11:26
  • $\begingroup$ Its hard to see anything significantly different in the image. If it is different it is most likely caused by modifiers. Also see blender.stackexchange.com/questions/70334/… $\endgroup$ – Duarte Farrajota Ramos Dec 29 '17 at 11:36
  • $\begingroup$ I didn't use decimate (or any other modifier), that is a manual edit of the vertexes. Here is an enlargement: i.stack.imgur.com/qxPaq.gif $\endgroup$ – Amaya Dec 29 '17 at 11:48
  • $\begingroup$ Possible duplicate of Blender mesh missing loop $\endgroup$ – Duarte Farrajota Ramos Dec 29 '17 at 13:21
2
$\begingroup$

Check if you have added Shape Keys to your model. This might have happened by accident. Shape keys allow you to define vertex location changes relative to the original model, and animate those location changes using a value slider. Kind of like recording a coordinate difference / offset. For character animation, this can be useful (search for corrective shape keys on this site).

When you add a new Key to a model in Blender, its influence parameter is set to 0.0 by default. That means, if you go back out to Object Mode, your model jumps back to its initial state. It's easier to show this in a short video:

Shape Key adding

As you can see, I'm adding the Basis Key (that's always the unaltered stage of the model) and a Key 1 to the model. I'm going to Edit Mode while Key 1 is still active, so I am defining a change within that key. When I tab back out to Object Mode, my changes disappear. But when I slide that Value Slider all the way to 1.0, my changes are back in place.

If this is your problem, Slide your Key 1 value to one, and then first create a new shape key from mix, and then remove all shape keys, while taking care that the new mixed key is the last one you delete:

removing keys

$\endgroup$
  • $\begingroup$ Sometimes js stops working when I use stackexchange... oh well, this looks like it was the cause of the issue. I created a new key and moved to 1.0 then the changes automatically appeared in the viewport. I'm trying to figure out how to deal with the already 23 existing keys now. $\endgroup$ – Amaya Dec 29 '17 at 12:49
  • $\begingroup$ @Amaya The "new key from mix" solution stated in the answer wil work with any number of keys. Whatever you see in Object Mode should become the content of the new key. On the other hand, if you don't care about them, you can also remove all keys at once, there is a command for that in the same shape key menu (Delete All Shapes). Better save the scene before you try that ;) On a side note, how come you have so many of them? Accident or on purpose? $\endgroup$ – aliasguru Dec 29 '17 at 13:33
  • $\begingroup$ I'm editing an existing project, I changed all keys to 1.0 to see the difference but nothing changed so I'm guessing they're just placeholders, or I messed up something when importing the project and some informations were lost. $\endgroup$ – Amaya Dec 29 '17 at 13:42
1
$\begingroup$

This is the result of viewport optimalisation in blender.

To resolve this you need to check Draw All Edges located in the object panel's display tab.

enter image description here

$\endgroup$
  • $\begingroup$ This didn't fix it but it was still useful, I was wondering why some edges were invisible. $\endgroup$ – Amaya Dec 29 '17 at 12:54
  • $\begingroup$ no problem, I noticed aliasguru's answer was more likely the solution. Best of luck! $\endgroup$ – Delagone Dec 29 '17 at 13:12
0
$\begingroup$

Is your mesh in wireframe mode? If you press Z it will go into wireframe mode and look similar I believe. You can also change it in the tab to the right of the “Edit mode” and “Object mode” tab.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.