0
$\begingroup$

I am very new to using Blender and I've been using the add-on "MMD_tools" to import MMD models into the program. The models themselves are imported fine but they're always missing all their textures when they are and I'm not entirely sure how to stop that from happening or how to add their textures back on?

$\endgroup$
2
1
$\begingroup$

This is an issue unique to MMD models in Blender due to the way MikuMikuDance understands shading, textures, and all things of that sort. When you open an MMD model in Blender, you might see something like this.

MMD model with textures tinted purple

(All of the following images are taken using the Blender 2.8 version of MMD tools)

There are several things we can try to get our textures looking normal and not so pink.

1. Disable Sphere Textures in the MMD Display tab. Open your Visibility Sidebar on the right (usually can be opened by pressing N ) and navigate to the tab titled Misc. Under the section MMD Display, uncheck the box next to Sphere Texture.

visual guide to the menus discussed

If this does not correct any or only a few of your textures, continue to the next step.

2. Disable Toon Textures in the MMD Display tab. Directly to the left of the Sphere Texture option from the last step, there should be an option titled *Toon Texture. Uncheck the box next to this option.

visual guide to the menus discussed

If this does not correct any or only a few of your textures, continue to the next step.

3. Turn off Use Shared Toon Texture. Selecting the mesh of your model, navigate to the Material Properties tab under the Properties panel. You should see a list of all the textures being used on your model.

enter image description here

Select a texture you see on the list that has the pink hue we're trying to get rid of. For example, these textures are supposed to be a pale yellow but they are appearing as a vibrant pink in my textures list.

image of textures experiencing errors in texture list

Once you have selected the texture, scroll down in the settings underneath the texture list until you find a section titled MMD Texture. There should be an option titled Use Shared Toon Texture in this section. Uncheck this option and see if the texture has gone back to normal.

location of options discussed above

If there is a part of your model that is bright purple still, there may be an issue with the model or a missing texture.

After trying these steps, your model should be back to normal. Mine turned back to normal once I unchecked Toon Textures in Step 2.

first model now without the pink hue

Something Important To Know

Some models rely on things like Toon Texture and Sphere Texture if they have a special shader attached to them (to make them look more anime-like, or because of the material the textures on it are trying to emulate). If you have a model that only has a few sections turning up pink try Step 3 first on those textures in order to have the model work correctly. However, this method can also be used if you don't want those shaders on your model!

$\endgroup$
1
  • $\begingroup$ In addition to the answer posted above, I followed all the steps shown but it didn't change anything. However, thanks to it I found a section under materials called MMD Texture with links to filenames. All the filenames were incorrect so I had to point it at the right files again and then it worked. $\endgroup$ Jan 16 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.