2
$\begingroup$

I am trying to make the light from a convex lens shine through haze in a volumetric scatter cylinder like this: https://www.behance.net/gallery/53917965/LENSES-TEST

I can see that my lens does concentrate a beam of light on the plane below the lens, however the volumetric cylinder below the lens depicts a perfectly even distribution of light...

enter image description here

Is there a way to make the volumetric light look like the scene linked above? Here is a wire frame to make it easier to understand how the scene is set up...

enter image description here

And the node setup for the volumetric scatter cylinder...

enter image description here

Here is how it looks if I enlarge the volumetric cylinder enough to envelope the entire scene. There should be a narrowing beam of light below the lens...

enter image description here

$\endgroup$
  • 2
    $\begingroup$ Seems to be working for me, is it possible you could upload your .blend? $\endgroup$ – gandalf3 Dec 24 '17 at 7:01
  • $\begingroup$ @gandalf3 - added blend file $\endgroup$ – disconnected Dec 24 '17 at 8:22
4
$\begingroup$

It is working, it's just not visible (yet). Try using the branched path tracer to sample more volume bounces per sample:

enter image description here

  1. Switch to the Branched Path Tracing integrator
  2. Set the number of volume samples to something large (you may also want to increase the samples for some of the other passes as well)
  3. Set the number of Anti-Aliasing samples. These correspond to the number of initial samples cast from each pixel (See What is branched path tracing and how is it useful? for more detail)
  4. Note the total number of samples per pass (21000 volume samples, and still not nearly enough!).

Here is your file rendered with the settings shown above (to get a better caustic on the diffuse plane, try increasing the number of diffuse samples a bit):

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Cheers for the solution. It looks like branch path tracing cannot use GPU and my CPU bogs after the first few samples, freezing my computer. Same result even if I limit the number of cores dedicated to rendering. Will have to try in the future with a better PC. $\endgroup$ – disconnected Dec 24 '17 at 18:41
  • $\begingroup$ @SailorJ The branched path method takes longer per sample, but requires fewer samples. So what looks like bogging down when compared to the progressive method is actually normal. It should work on GPU though, if I'm not mistaken. What happens when you try to switch to GPU? $\endgroup$ – gandalf3 Dec 25 '17 at 0:42
  • $\begingroup$ @SailorJ Also, you might want to give luxrender and its bidirectional path tracer a try. Cycles does backwards path tracing (that is, it traces light paths from the camera until they hit a light source), which is more efficient than forward path tracing (trace rays from lights until they hit the camera) but not really the best for caustics and fancy optical stunts. $\endgroup$ – gandalf3 Dec 25 '17 at 0:46
  • $\begingroup$ My mistake. I thought that all four processors pegged at 100% meant I was rendering the view port with the CPU. GPU is working for the actual render and doesn't freeze. I had looked at Luxrender for a prism refraction (rainbow) effect. Will try with this too. Thanks again. $\endgroup$ – disconnected Dec 25 '17 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.