I'm doing a scene with a room with a table. On the table I have some wine glasses, but I get this strange light from some of them. The glass to the left looks OK, but the other are not OK. It seems like they are affected by the floor texture!? Or what could be wrong?

I'm almost certain I didn't have this problem when I made the first test render. Then I just tested to see how the wine glasses was effected when I activated the Reflective Caustics and Refractive Caustics, then they got this strange light, but despite that I have unchecked the both Caustics options in the render tab, I still have this light and I don't know how to get rid of it? Any ideas someone?

The wine glasses har not solid. I have used a solidify modifier for the upper part of the glass, while the lower part is more solid. I'm only using the Glass BSDF node.

enter image description here

  • 4
    $\begingroup$ We are going to need a lot of information about your model for any serious answer, like topology, modifiers, material setup, render settings etc. Please edit your question and provide some screenshots $\endgroup$ Dec 20, 2017 at 23:34
  • $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information. We don't know how you set up your project or your textures or render settings. Consider sharing your .blend file (with the images used as textures packed into the file) so that others can inspect it. You can upload it at blend-exchange.giantcowfilms.com and then paste the resulting link as part of your question. $\endgroup$
    – user1853
    Dec 20, 2017 at 23:56
  • 2
    $\begingroup$ It looks to me that it could be a problem with the floor material rather than the glass - as if it’s visible to the camera but not when viewed indirectly (through the glass). Try changing the IOR of the glass to 1.0 to make it act as plain transparent - this will eliminate the refractive distortion so you can see what’s happening. Check the floor material for Light Path conditions - eg, is it only visible to camera rays so allowing the environment to shine through when viewed indirectly? $\endgroup$ Dec 21, 2017 at 7:30
  • $\begingroup$ @RichSedman Thanks for your suggestions, but nothing helped. I changed the IOR to 1.0, but still the same white light and the settings for the floor below the Light Path are the usual. If I remove the texture and just use a diffuse color, still the same problem. Any other ideas that could solve this? $\endgroup$
    – 3D-kreativ
    Dec 21, 2017 at 8:33
  • 1
    $\begingroup$ @RichSedman Now it's definitely solved. The scene has two rooms and each room has it own floor object. When I was looking for the settings for the floor, I clicked on the floor near the camera, but that was not the floor in the background behind the wine glasses, it vad the other floor object and now when I clicked on that floor, I discovered that the Transmission option below the objects Cycles Settings was deactivated. Now when this is selected again it works fine without the solution I wrote about before. :) $\endgroup$
    – 3D-kreativ
    Dec 21, 2017 at 9:37


You must log in to answer this question.

Browse other questions tagged .