3
$\begingroup$

I created a simple bottle and applied a glass material using the new principled shader. When it comes to rendering the surface of the bottle turns out incredibly noisy, except the part on the front that looks like glass. I tried several solutions with light paths, sampling settings etc. but it doesn't change anything. Any thoughts on that? :-)

Heavy noise on glass bottle

$\endgroup$
  • $\begingroup$ It’s strange that one part would be rendered fine but the rest is so noisy.... things to try : move the camera - does this affect how each surface is rendered? Rotate the object - does this affect how each surface is rendered? Check the geometry - overlapping faces, remove doubles, recalculate/flip normals. If none of this helps, upload screenshots of anything that might help - geometry, modifiers, nodes, etc. and upload the blend file if possible. $\endgroup$ – Rich Sedman Dec 20 '17 at 13:36
  • $\begingroup$ I added the blend file! Rotating the object doesn't help. Mesh seems fine to me. $\endgroup$ – drmarzipan Dec 20 '17 at 14:02
  • 1
    $\begingroup$ You can do a simple test: Render it without your Background. You'll see that the noise appeared only where the bottle reflected your Background. (All the noise is in the indirect gloss pass). As the model and the material seem to be fine, I think it really just comes down to using more samples. (Or denoise). Also, use at least a simple diffuse shader for the background. But still, I'm curious if anyone can find a better solution. $\endgroup$ – michaelh Dec 20 '17 at 15:39
  • $\begingroup$ The way to minimize noise is to render using more samples. Using the denoiser might help. Also if the noise is coming from the background, enable "Multiple Importance" in the World> Settings. $\endgroup$ – cegaton Dec 20 '17 at 15:41
  • 2
    $\begingroup$ @drmarzipan when you share a file please pack the images into the file Otherwise those who open your file will only get a lovely pink color instead of the images. $\endgroup$ – cegaton Dec 20 '17 at 21:04
0
$\begingroup$

Your lighting is using very bright mesh lamps and this isn't helping. You can get much better results by using Area lamps instead. Also, Branched Path Tracing can produce much better results with significantly less samples.

Here are the result I got with just a little tweaking :

final results

This is simply using two Area lamps replacing the mesh lamps (scaled to the same size), each with Emission of 15 and with my own HDR image for environment (yours was missin). I swapped to using Branched Path Tracing, removed Clamping and Light Sampling limits and adjusted the Samples to favour Diffuse and Glossy. I also set the Render AA Samples to 10.

$\endgroup$
  • $\begingroup$ can you elaborate on the difference between area lamps and Planes with emission shaders? $\endgroup$ – cegaton Dec 21 '17 at 0:00
  • $\begingroup$ @cegaton I always thought area lamps were much more efficient than mesh lamps but I've just re-tried some comparisons and can't see much difference, to be honest. I'll need to look into that a bit more I think. The presumption was that the render engine could optimise area lamps more effectively - certainly you can set Multiple Importance Sampling on an area lamp - but I can't see much actual difference now. I think the main difference for the original question is to use Branched Path Tracing without Clamping. $\endgroup$ – Rich Sedman Dec 21 '17 at 0:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.