0
$\begingroup$

I have the following CUDA error when trying to render my project in cycles:

CUDA error: Launch failed in cuCtxSynchronize(), line 1372

My scene rendered well some days ago. After adding new elements and models the error appeared. I had this error already some time ago, while working on this project, but after changing the content and sample amount in the render settings it disappeared until today.

I am using a GeForce 1080 Ti with 11 GBytes of Ram. The scene use currently not much vram of my graphic card. So the vram can not be the reason.

Any ideas for a solution please? Maybe some developers are reading this too.

Thank you a lot for any tips

Chris

enter image description here

$\endgroup$
2
$\begingroup$

I struggled with this problem for months. Used different computers, re-installed Blender, re-installed windows (I am using 8.1 & 10), installed new and old drivers for my Nvidia card, changed the TDR and everything I could think of...but no luck.

Then it occurred to me that the Gforce Experience runs in the background (and being in my opinion, not a well written program) may be overlapping the memory of Blender or at least hogging the memory. So I un-installed it and magic!!! All Cuda errors and memory errors went away. Blender works again as it should!!!

I hope this works for you, as it did for me. Unfortunately, I did not discover this for months, until I had pulled every single strand of hair out of my head.

$\endgroup$
  • $\begingroup$ Thank you for your answer. This is interesting. I have not tried your solution yet but there is an article I have written to solve the issue even if you have GForce Experience running and don't want to uninstall it. Here ist the link to my article: christoph-werner.de/2017/12/31/… I forgot to mention it here. $\endgroup$ – Christoph Werner Mar 31 '18 at 16:23
  • $\begingroup$ Thank You for your reply' I can see that you are very experienced and that was a nice link to your report. For me, the TDR changes did not solve it. If I re-install "The Experience" The issue returns. Since Blender is more important to me and I can do manual driver updates, I choose to keep a functioning Blender. $\endgroup$ – Royov Apr 1 '18 at 4:53
  • $\begingroup$ Have you tried higher TDR values like I mention it in my article to increase the waiting time? Sometimes 30 seconds are far not enough. Greetings. $\endgroup$ – Christoph Werner Apr 1 '18 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.