1
$\begingroup$

I'm making an aircraft model for a game, but I'm having trouble with Unwrap on subsurf'ed parts that have had boolean cuts applied to them. I meticulously plan out nice seams using the Mark Seam function: seams But it seems like the Unwrap functionality just generates a random jumbled mess of vertices without any structure: random unwrap UV smart project does kinda make sense of the unwrap, but it puts extra seams where I don't want them: uv smart project I suspect there's either a bug in Unwrap somewhere, or what I'm doing is making no sense. When I hit "Unwrap" after UV smart project, it partly redoes the UV mapping of some vertices, but stops part way through, so the UV unwrap now looks like a hybrid of the UV smart project output and the random jumbled mess of Unwrap: unwrap after uv smart project Might the booleans have somehow messed up my object? I noticed it does tend to product a whole bunch of redundant and doubled vertices, but I've tried to "Remove doubles" on this already: doesn't help. "Recalculate outside" for normals: doesn't help. "Apply scale & rotation": doesn't help. Basically once I get an object into this state, nothing seems to help it anymore except to use UV smart project from this point forward and accept the imperfect UV mappings it products.

$\endgroup$
3
$\begingroup$

The issue is unclean geometry left from boolean - specifically this area:

enter image description here

There is very thin long face running alongside the wing's trailing edge that is causing the problems. Only the top surface of the wing does not unwrap correctly, if I select other parts separately, they unwrap individually fine, so the problem is localized to that area only.

If you clean up that geometry, the model will unwrap correctly. Unfortunately removing doubles or recalculating normals won't help, it looks like some nasty leftovers from ngons.

$\endgroup$
  • $\begingroup$ Thanks, I believe I've figured it out. By messing around with those upper faces and placing seams carefully, I've been able to convince Blender to do the unwrap in a sensible way. $\endgroup$ – toto Dec 19 '17 at 14:08
0
$\begingroup$

Red points in UV/image editor means that you've used Pin option.

Unpin vertex by selecting all of them in UV/image editor, then press Alt + P

After this, retry to make UV

$\endgroup$
  • $\begingroup$ Thanks, tried that. It now produces an absolutely bizarre unwrap, where all points fall on one line: i.imgur.com/N6efORW.png $\endgroup$ – toto Dec 19 '17 at 12:41
  • $\begingroup$ Check that you unpin all vertexes, including selecting in 3d-view $\endgroup$ – Crantisz Dec 19 '17 at 12:42
  • $\begingroup$ I made absolutely 100% sure to do so by hitting "A" several times in the 3d view to make sure every vertex was selected, then proceeded to unpin it all in the UV editor. $\endgroup$ – toto Dec 19 '17 at 12:49
0
$\begingroup$

You'll have to start the unwrapping process over and make a few tests for common errors:

1 - Edit mode > W > Remove Doubles - sometimes we create duplicated vertices by accident and they royally screw the UV

2 - Edit mode > Select evrerything you want to unwrap (or just press a until everything is lit if you want to unwrap all the mesh) > Ctrl+E > Clear Seams. This will erase any direction about where to cut the mesh in the uv

Edit mode > Select evrerything you want to unwrap (or just press a until everything is lit if you want to unwrap all the mesh) > U > Unwrap. We won't use this unwrap, but we need to make sure it's clear

UV/image editor screen > select all > Alt+P. This will remove any pins and avoid having a pinned vertice stuck again.

After that, 3d View > Edit Mode > selection by Edges > Select the edges where you want to open the UV > Ctrl+E > Mark Seam.

After everything is nice and marked, Select all > U > Unwrap

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.