I am new to blender and have been having issues with something I thought is relatively simple.

I tried looking for answers to this but could not find anything that can help me.

Basically, I followed a video to create a "simple" heart shape mesh using 2 cylinders and a cube I had combined them into a single shape, removing the overlapping part with Boolean modifier.

However, when I tried to use it to cut the shape into a cube, I can't get it to work properly.

I noticed that the heart mesh has the sides of the cube connecting to the half cylinders have multiple faces etc. But the model appears to be air tight.

Can I get some suggestion as to the easier to go about doing this or fixing the issue I am having?

Any pointers will be very much appreciated.

p.s. I wanted to upload the heart mesh I have but I don't know how - I am new to this forum too.

Edit: Here is the example of what I am trying to do.

I wanted to create an mesh (in this case a heart) as follows:

Hear Mesh

Then use it to cut into another mesh as follows:

Setup for cutting

Boolean does not work as expected even if I tried making the cut using Boolean modifiers the cube first, then the cylinders separately one at a time.

The tried various combinations of combining the heart mesh, playing around with the mesh, applying the mesh as separate components etc but cannot get Boolean modifier to work.

What would be the best way to accomplish something like this or a cut through? I know it works for simple shapes but not for primitive shapes.

Thanks again.

Edit: Here is the heart mess sample for cutting. Thanks.


1 Answer 1


Your specific problem (based on your blend file) is a faulty heart mesh. If you press z to see the wireframe mode and this will become obvious. You need to have a mesh that does not contain inner geometry or walls, or double edges/vertices, which this mesh contains both. Unfortunately the tutorial and method you were following to create the heart is "simple", but rather faulty and bound to get you into trouble in the future.

enter image description here

These mesh issues caused an inaccurate polygon in the cutout, which could be fixed fairly easily.

enter image description here

You could also clean up your cutout mesh, but it's not worth the work. I recommend making a more accurate and stable mesh, using the following steps:

  1. Create a cylinder (shift+a).
  2. Go to edit mode (tab).
  3. Turn on proportional editing o, and change the mode to sharp.
  4. Select the top, center vertices, and scroll the mouse wheel while grabbing them (g) until you have the desired result.
  5. Do the same for the bottom.

Here is an animation demonstrating the process.

enter image description here

To perform the cut, use the following steps:

Add a boolean modifier and set it to difference.

  1. Select the mesh which needs the hole in it. (not the mesh to make the hole!)

  2. Go to the modifiers tab and add a boolean modifier.

  3. Set the type to difference, and the object to the shape to make the hole (your heart shape).

  4. Apply the modifier.

  5. Select and delete the heart shape (or just move it away).

There now should be a heart shaped hole in the mesh.

Add a boolean modifier

Set to difference and select object

The finished hole

If you want another option, enter edit mode (tab), add a little more geometry (ctrl+r for loop cut) and use the cut out tool (k) to manually cut out the geometry. Before doing this you will want to switch to orthographic view (numpad 5) and top view (numpad 7) to get the proper cuts. Then disable limit selection to visible (see image) so it will cut all the way through the mesh, and click where you would like to cut. When you are done, press enter to finish the cut. If you would like to cancel push esc. I hope this helps.

enter image description here

enter image description here

Here is my blend file.

  • $\begingroup$ Hi Snail, thanks for the reply. I had been using the Boolean method but it seems to work only for simple shapes. I have not problem with cylinders, or rectangles but it does not like a composite shape like the heart mesh, which is made up of a cude and 2 cylinders. The second method will work for relative simple shape but will be quite difficult to make a complex object like a more well rounded heart shape. $\endgroup$
    – George
    Dec 19, 2017 at 4:06
  • $\begingroup$ It worked for me. I just created a heart and cut it out. I'll post the image. I suspect that the culprit is double vertices on your cutter (heart) mesh. Try using the circle selector to select all vertices at the spot where the square and sphere joined, and then press alt+m to merge them, and choose an option. You can easily check if there are two vertices in the same place by going into edit mode and pressing "remove doubles" on the toolbar. If on the top status bar it shows vertices were removed, you can be sure there were issues. $\endgroup$ Dec 19, 2017 at 4:17
  • $\begingroup$ If you want to make sure your mesh itsn't the culprit make a new one starting with a cylinder. Go to edit mode, turn on proportional editing, change the mode to sharp, select the top center vertices, and scroll the mouse wheel while grabbing them until you have the desired result. Then do the same for the bottom. That ensures that your mesh is good, with no gaps or double vertices, not to mention it is way easier and I could make a heart shape in about 30 seconds. :) $\endgroup$ Dec 19, 2017 at 4:19
  • $\begingroup$ I am working on uploading a blend file right now. $\endgroup$ Dec 19, 2017 at 4:25
  • $\begingroup$ @George Just a thought, try removing double vertices on the heart, and possibly on the mesh you want to cut into as well. Go into edit mode and hit Ctrl V followed by R. You may also need to apply scale and rotation. In object mode hit Ctrl A followed by O. $\endgroup$
    – user27640
    Dec 19, 2017 at 4:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .