2
$\begingroup$

I'm trying to have a surface with soft body hold obects that are falling on it with rigid body physics, but for some reason, no what matter what mass I give it, the objects just fall trough the softbody enabled surface.

Is there a toggle or a value I need to change to make them stay there?

$\endgroup$
7
$\begingroup$

Normally, soft bodies react to the presence of rigid bodies - providing those rigid bodies have Collision enabled - but the opposite does not occur; ie, the rigid body will not react to the presence of the soft body. This will result in the rigid body 'pushing through' the soft body :

rigid body pushing through

In order to have the rigid body react to the soft body, the soft body must be made to be part of the rigid body world. This can be achieved by adding Rigid Body physics to the Soft Body as well as it being part of the soft body world.

To achieve this, enable Rigid Body in the Physics panel and set the Type as 'Passive' so that the Rigid Body simulation doesn't directly affect the soft body mesh (we'll leave the soft body engine to deal with that). Also, set it to be 'Animated'. In Rigid Body Collisions set the Shape to 'Mesh' and enable 'Deforming' since the mesh will be deforming during the animation.

rigid body settings on the soft body

The rigid body should now interact with the soft body :

rigid body react to soft body

Blend file included

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.