This question already has an answer here:

I'm having some problems with cutting a mesh. This is how the cut looks on Edit mode:

enter image description here

and this is how it looks on Object mode and how the model stays on Pose mode too:

enter image description here

any idea of why is this happening?

I've checked all faces existing, and also used the knife tool, but the result is the same. In some cases it even just ignores the whole loop.

marked as duplicate by Duarte Farrajota Ramos, David Dec 17 '17 at 1:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 1 down vote accepted

Check the Draw All Edges checkbox in the object properties panel.

Not the answer you're looking for? Browse other questions tagged or ask your own question.