1
$\begingroup$

In the picture you can see my model in the edit mode. In the render mode it is not looking the same. It got some weird other vertices lining up, and I don't want that it looks like this! What have I done wrong? please tell me. Thank you

klick to see image

$\endgroup$
  • $\begingroup$ You probably have a modifier enabled that does it, whose effect doesn't show in Edit mode. Possibly decimate. Disable, or reduce it's strength. $\endgroup$ – Doyousketch2 Dec 15 '17 at 21:00
  • $\begingroup$ Im just using a mirror-modifire. $\endgroup$ – nobody_JH Dec 15 '17 at 21:02
  • $\begingroup$ Check the clipping setting on it. Make sure it's enabled, so no vertices are going through the mirror axis. $\endgroup$ – Doyousketch2 Dec 15 '17 at 21:05
  • $\begingroup$ already done it $\endgroup$ – nobody_JH Dec 15 '17 at 21:17
  • $\begingroup$ should I give you the file ? $\endgroup$ – nobody_JH Dec 15 '17 at 21:17
3
$\begingroup$

You've done nothing wrong. The extra edges and faces you are seeing are caused by the rendering process. Graphics cards can only deal with triangles, thus everything is converted to triangles before rendering (not permanently though). There are some ways to make it less apparent though. First is to make sure your faces are as flat as possible. If the faces aren't flat along their normal there will always be some sort of edge visible due to the face being split int 2 triangles. The other option is to manually split any faces where it is very noticeable into triangles manually so that you have control over where the edge goes.

Depending on what you are trying to do, you may be able to render using the OpenGL render that blender has, which will render the viewport, and not triangulate the faces.. Doing so won't allow you to have the same amount of controls or options as using a render engine would, but for non realistic renders especially it can be quite useful.

One final thing to try is to use an edge split modifier or auto smooth the normals. Both of these will require your model shading to be set to smooth, and will render angles over a certain limit as sharp edges. Assuming your faces are all relatively flat you could probably find an angle that would render the faces flat and the edges sharp.

$\endgroup$
  • $\begingroup$ I will use it for a map in another program (hammer). Is it just not working in the blender render, or can I import it easily into the other program engine? And thank you for the detailed awnser :) $\endgroup$ – nobody_JH Dec 15 '17 at 21:12
  • $\begingroup$ Auto smooth worked!!!! Thank you very much! :) $\endgroup$ – nobody_JH Dec 15 '17 at 21:19
  • $\begingroup$ @nobody_JH Don't just thank in the comments, if an answer solved your problem consider marking it as accepted, otherwise at least upvote it if it helped you. $\endgroup$ – Duarte Farrajota Ramos Dec 16 '17 at 1:03
  • $\begingroup$ Ok, sry ! I am new :/ but hank you! $\endgroup$ – nobody_JH Dec 16 '17 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.