1
$\begingroup$

I'm trying to render this underwater scene, but somehow, I can only get this much to show:

enter image description here

Here is my suspect: I was following a part of this tutorial: 18 ways to speed up cycles rendering and I only reduced light bounces, changed tile size and used the denoiser. However, I retraced all those steps but they don't seem to be the cause. I really try to not overlook anything, though.

So, I don't know exactly what I did wrong (otherwise, I wouldn't be asking for help). So I would really appreciate if you can suggest how I can solve this.

I also read other similar threads about rendering all black, but haven't found anything that could apply to my case.

Here is the blender file.

Appreciate any help, TIA!

$\endgroup$
  • 2
    $\begingroup$ The value for volume scatter is too high. $\endgroup$ – cegaton Dec 15 '17 at 4:13
  • $\begingroup$ Thanks! That node was leftover from a tutorial that didn't work. So I deleted it. However, now if I render I can see the green patch of the pond but everything else is still black. So the issue is still there... $\endgroup$ – Pipou Dec 15 '17 at 4:19
  • 1
    $\begingroup$ Please try to be more specific, don't make your question dependent on downloading a file only, most questions can be answered without one if there is enough information. Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and try to clarify the issue. Add images that can guide others to understand the problem. I did open your file but I (or others) might not want to spend hours trying to understand what you did and didn't do. $\endgroup$ – cegaton Dec 15 '17 at 5:35
  • $\begingroup$ Yes, of course. Sorry cegaton, I was panicking a little and didn't have a clue. For the past hour I've been trying to solve this problem so I'm updating my question now. $\endgroup$ – Pipou Dec 15 '17 at 5:56
2
$\begingroup$

A few issues with your file:

You have a big cube.001 that is not visible in the viewport (eye icon) but that is rendereable (camera icon) that blocks everyting. Get rid of it.

Then you have an object (cube) that is a big block of glass and volume scatter. The volume scatter is set at a value of 0.2. bring it down to 0.05 and you'll see your objects will start to show.

What are you trying to accomplish with the glass shader? Unplug it.

If you are looking for the reflection of the water surface use a different plane for that.

Then you have a bunch of objects called circle.xxx that are disabled for render and that have materials done in blender internal. You have to recreate those materials in order to use them in cycles.

The edges of the big cube that you are using as water is visible in the shot. Is this a pond or a fish tank?

Why is the lamp inside the water? Also, the light was set using blender internal materials and in cycles it needs to be an emission shader. And it needs to be quite bright to compensate for the volume scatter in the water.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks cegaton, Bringing down volume scatter definitely made a huge change. The big cube was the fluid in the fluid simulation. I'll put it to a different layer. I was thinking to work on the fluid before its walls and ground. By using a plane do you mean with the ocean modifier? Using volumetric shader works nicely for lighting but I still like those water splashes very much. I'll find a way to workaround this. Maybe using two cameras (above & underwater) for two different shaders. How do you know if something was done in blender render? The lamp my attempt to fight the darkness... $\endgroup$ – Pipou Dec 16 '17 at 3:12
  • $\begingroup$ Sorry for the wordy reply. Didn't know there'd be no paragraph breaks in this section. $\endgroup$ – Pipou Dec 16 '17 at 3:18
  • $\begingroup$ Materials in blender render are very different. Incompatible with cycles. A lamp in cycles uses emission shaders. To ask new questions please use the big blue Ask Question on the top of the page. This site is not a forum for long conversations. For a more relaxed way to have conversations use the Chat Rooms on this site $\endgroup$ – cegaton Dec 16 '17 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.