This question already has an answer here:

I think it would be faster to render with my gpu, but I can't seem to select it.

My GPU is an MSI gtx 1050 ti

enter image description here

marked as duplicate by Duarte Farrajota Ramos, David Dec 15 '17 at 17:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    please edit your question and add what GPU you have. What does the "Cycles compute device" in the system tab of the user preferences say?? – David Dec 15 '17 at 2:30
  • @David I just set it to CUDA it works now, it's only about 14 seconds faster though. Is it common for people to use their gpu or cpu? – J. Czekaj Dec 15 '17 at 3:31
  • if you have a good gpu then use it! 1050ti is a decent card, not super powerful, but like you saw even that can out perform a cpu. – David Dec 15 '17 at 3:32
  • 3
    PS please do not add "Solved" to a question. It would be better if you wrote an answer, and explained what you did to turn on GPU rendering. – David Dec 15 '17 at 3:41

Press ctrl + alt + u to open the "User Preferences".

Switch to the "System" tab and change your compute device.

enter image description here

(I do not have a compatible GPU, but yours should show up here, if it is compatible.)

I recommend clicking "Save User Settings" so that this is saved for next time you open a new Blender file.

Your GPU should now appear under the GPU compute section.

Not the answer you're looking for? Browse other questions tagged or ask your own question.