2
$\begingroup$

I recently recorded a short tutorial video (not for Blender) using TechSmith SnagIt 11 and wanted to edit and render it in Blender. This works fine except for one thing: After having imported the video into the VSE the colours all look really dull: for instance, what was originally pure white is now #C9C9C9... It's also not just a display issue - it also looks like this when I render the video out again. It does look fine when playing back the original video in VLC.

Here's part of an original frame from source video (left) and (approximately) the same frame as it appears inside Blender 2.79 and after render (right):

Original in Blender

Any ideas what could be going on here and how best to fix it (ideally without having to rerecord the original video)?

In case it helps, this is the codec information reported by VLC for the original video:

Type: Video

Codec: H264 - MPEG-4 AVC (part 10) (avc1)

Resolution: 1280x738

Display resolution: 1280x720

Frame rate: 8.043657

Decoded format: Planar 4:2:0 YUV

$\endgroup$
  • 1
    $\begingroup$ Sound like the colorspace isn't embedded in the file in a way Blender can detect/read. Would you mind uploading a sample mp4 recorded in the same manner? $\endgroup$ – Leander Dec 14 '17 at 10:41
  • 2
    $\begingroup$ @Leander, thanks for chiming in, but it was my bad. See my answer. Funny how one always seems to find these things out immediately after having spent half a day hunting for the problem and finally deciding to post to SE... ;) $\endgroup$ – Oliver Giesen Dec 14 '17 at 10:56
  • 2
    $\begingroup$ Possible duplicate of White background with filmic blender $\endgroup$ – cegaton Jan 26 '18 at 16:39
  • $\begingroup$ @cegaton: I don't think marking this as a duplicate would help others with the same problem. While the cause for the problem in the question you quote might indeed be the same, the (correct) answer given there would not have solved the problem presented here at all as there are no light sources whose intensity could be increased... $\endgroup$ – Oliver Giesen Feb 15 '18 at 14:21
1
$\begingroup$

Nevermind, it was my mistake: I had changed the default colour management in the Blender startup file to the new "Filmic" rendering and apparently, that's not what you'd want to use in this case... After changing it back to "Default" everything looks as intended.

I guess a new question could be: How would I handle this in a scenario where I actually want to use Filmic, e.g. if I were to set up a 3D scene where this video was shown on a TV screen? How would I have to adjust the settings for the video to display with its original colours?

$\endgroup$
  • $\begingroup$ I would suggest writing your question as an actual new StackExchange question, rather than discussing that here in an answer. $\endgroup$ – dr. Sybren Dec 14 '17 at 11:46
  • $\begingroup$ I agree. However, as it's just a hypothetical question for me at the moment, I'm not in a particular hurry. I mainly put that paragraph in the answer to gauge potential interest in other facets of the issue that might be of more benefit to others than this one turned out to be... $\endgroup$ – Oliver Giesen Dec 14 '17 at 14:42
  • 3
    $\begingroup$ "Correct" colors with filmic Blender already have lots of answers. $\endgroup$ – Leander Dec 14 '17 at 16:16
  • $\begingroup$ Thanks for the link! That was very informative even though I was already aware of the general concept. It doesn't really explain the phenomenon discussed here for me though: As far as I understand, Filmic will look for the highest intensity in the "source" and then scale everything down so that maximum intensity becomes 1.0. However, in this case, the source was already sRGB-based and thus couldn't possibly contain any intensities > 1.0, or could it? Why then would Filmic "downscale" the existing whites in the image? But I digress. This is definitely out of the scope of my original question... $\endgroup$ – Oliver Giesen Dec 14 '17 at 17:50
  • 1
    $\begingroup$ Agree with @dr.Sybren here, ask a new question. $\endgroup$ – troy_s Dec 20 '17 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.