I have a model which you can see here (camera perspective).

enter image description here

In the second image, you can see how the render turned out.

enter image description here

I'm at my wit's end trying to figure our why it's not showing up in the render. If anyone needs more information, just ask and I'll get it to you. I've already checked the normals and they're not the cause.

  • $\begingroup$ related: blender.stackexchange.com/questions/33787/… (while this link was created later, the answer is more universally useful) $\endgroup$
    – zeffii
    Commented Jul 11, 2015 at 13:22
  • $\begingroup$ Another reason can be keyframes. You move an object to place it in front of the camera, hit render... And it doesn't render because you didn't key the location in front of the camera $\endgroup$ Commented May 5, 2017 at 3:37
  • $\begingroup$ I don't have the reputation to answer this question, but if your object has any particles / hair you may have "Show emitter" disabled in the ParticleSettings $\endgroup$
    – Ian Hunter
    Commented Apr 28, 2020 at 0:13
  • $\begingroup$ @IanHunter I had the same issue and your suggestion solved my issue! Thanks! $\endgroup$
    – Daniel
    Commented Apr 9, 2023 at 13:16

3 Answers 3


In object mode press W -> clear all restricted render. That will make all objects visible in the render. Also you can select and object and hit Ctrl+Alt+H to unrestrict render on the selected object. If there are objects that you have that you do not want rendered you can click the camera button next to the objects name in the outliner which is usually the top right window. This toggles camera visibility.

Version 2.80+ : Press F3 to bring in the search operator and type clear all restrict render.

  • $\begingroup$ Thanks. This fixes it. I must have bumped something there. $\endgroup$
    – Luke_0
    Commented Jun 12, 2013 at 18:42
  • $\begingroup$ I've actually done that several times myself. Probably from hitting W in object mode and immediately clicking while the object is selected. $\endgroup$ Commented Jun 12, 2013 at 18:48
  • $\begingroup$ I have found that problem a strange amount of times. Each time I am pretty sure I never pressed W. Can you revert it pressing W, because each time that happens I have to go down the object outliner and toggle venera $\endgroup$ Commented Mar 27, 2015 at 18:51
  • $\begingroup$ Oops. I wish I could edit that comment because I accidentally pressed 'post.' As I as saying: ... and toggle RENDERABLE (that auto correct) for each individual object. $\endgroup$ Commented Mar 27, 2015 at 18:53
  • $\begingroup$ I tried all the answers in this thread, but in v2.91, it seems that the option is now called Clear render region. All my objects was selected as "To be rendered" into the object explorer tree, but I noticed the object that wasn't displayed was a duplicate. So in the object that is not rendered, go to object properties, and check under Instancing that the Render checkbox is ticked. $\endgroup$
    – Alex
    Commented Jan 26, 2021 at 12:04

Also check duplication setting of the object. I copied a part of existing mesh and separated the copied part to a new mesh. After doing this, Duplication setting for this new object was set to "Group". I changed it to "None" and the object finally appeared in rendered view.

Correct Duplication Setting

  • $\begingroup$ I wasted an entire morning trying to figure that one out. If anyone knows what these duplication setting are about and how they affect rendering, I think an expansion of this answer is in order $\endgroup$
    – jollarvia
    Commented Apr 9, 2016 at 17:13
  • $\begingroup$ These are to create dupliverts, dupliedges and duplifaces. $\endgroup$ Commented Dec 26, 2016 at 11:10
  • $\begingroup$ Oh goodie, this one is tricky. I copied parts of a sphere out of it, and it was set to group. Setting it to none made the object appear. $\endgroup$
    – j4v1
    Commented Mar 3, 2017 at 16:35
  • 3
    $\begingroup$ I tried all the answers in this thread, but in v2.91, it appears that we do not have the Duplicate submenu anymore. So in the object that is not rendered, go to object properties, and check under Instancing that the Render checkbox is ticked. $\endgroup$
    – Alex
    Commented Jan 26, 2021 at 12:04

Alternatively, next time you can check to see if anything has been disabled from being rendered. Just bring up the Outliner and look to see if the camera beside it is grayed out. I myself sometimes hit this by accident sometimes.

The shortcut to do this is Ctrl + H to turn rendering off.

Ctrl+Alt + H to turn it back on.

The other two are the eye and the cursor which means an object is invisible and disabled from being selected respectively.

enter image description here

  • $\begingroup$ When the camera icon is green, what does it mean? $\endgroup$ Commented May 14, 2019 at 14:31
  • $\begingroup$ if it's green, it has a keyframe on a different frame $\endgroup$
    – user27460
    Commented Oct 11, 2019 at 2:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .