36
$\begingroup$

I have a model which you can see here (camera perspective).

enter image description here

In the second image, you can see how the render turned out.

enter image description here

I'm at my wit's end trying to figure our why it's not showing up in the render. If anyone needs more information, just ask and I'll get it to you. I've already checked the normals and they're not the cause.

$\endgroup$
  • $\begingroup$ related: blender.stackexchange.com/questions/33787/… (while this link was created later, the answer is more universally useful) $\endgroup$ – zeffii Jul 11 '15 at 13:22
  • $\begingroup$ Another reason can be keyframes. You move an object to place it in front of the camera, hit render... And it doesn't render because you didn't key the location in front of the camera $\endgroup$ – MicroMachine May 5 '17 at 3:37
41
$\begingroup$

In object mode press W -> clear all restricted render. That will make all objects visible in the render. Also you can select and object and hit Ctrl+Alt+H to unrestrict render on the selected object. If there are objects that you have that you do not want rendered you can click the camera button next to the objects name in the outliner which is usually the top right window. This toggles camera visibility.

$\endgroup$
  • $\begingroup$ Thanks. This fixes it. I must have bumped something there. $\endgroup$ – American Luke Jun 12 '13 at 18:42
  • $\begingroup$ I've actually done that several times myself. Probably from hitting W in object mode and immediately clicking while the object is selected. $\endgroup$ – Adam Masters Jun 12 '13 at 18:48
  • $\begingroup$ I have found that problem a strange amount of times. Each time I am pretty sure I never pressed W. Can you revert it pressing W, because each time that happens I have to go down the object outliner and toggle venera $\endgroup$ – TheMinecraftMan757 Mar 27 '15 at 18:51
  • $\begingroup$ Oops. I wish I could edit that comment because I accidentally pressed 'post.' As I as saying: ... and toggle RENDERABLE (that auto correct) for each individual object. $\endgroup$ – TheMinecraftMan757 Mar 27 '15 at 18:53
18
$\begingroup$

Also check duplication setting of the object. I copied a part of existing mesh and separated the copied part to a new mesh. After doing this, Duplication setting for this new object was set to "Group". I changed it to "None" and the object finally appeared in rendered view.

Correct Duplication Setting

$\endgroup$
  • $\begingroup$ I wasted an entire morning trying to figure that one out. If anyone knows what these duplication setting are about and how they affect rendering, I think an expansion of this answer is in order $\endgroup$ – jollarvia Apr 9 '16 at 17:13
  • $\begingroup$ These are to create dupliverts, dupliedges and duplifaces. $\endgroup$ – Spooikypok_Dev Dec 26 '16 at 11:10
  • $\begingroup$ Oh goodie, this one is tricky. I copied parts of a sphere out of it, and it was set to group. Setting it to none made the object appear. $\endgroup$ – j4v1 Mar 3 '17 at 16:35
16
$\begingroup$

Alternatively, next time you can check to see if anything has been disabled from being rendered. Just bring up the Outliner and look to see if the camera beside it is grayed out. I myself sometimes hit this by accident sometimes.

The shortcut to do this is Ctrl + H to turn rendering off.

Ctrl+Alt + H to turn it back on.

The other two are the eye and the cursor which means an object is invisible and disabled from being selected respectively.

enter image description here

$\endgroup$
  • $\begingroup$ When the camera icon is green, what does it mean? $\endgroup$ – Leonardo Castro May 14 at 14:31

protected by Community Jul 30 '15 at 15:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.