1
$\begingroup$

Not sure what is really going on. But every time i try and bake the texture atlas it is much brighter then the material view.

here is before material/texture view: enter image description here

And here is the baked atlas view: enter image description here

All material nodes are just an image

  1. texture color > diffuse color
  2. diffuse bdsf to > material output surface

    And my bake is just literally diffuse and color. Anyone ever experience anything like this before?

Added my bake options:

enter image description here

$\endgroup$
  • $\begingroup$ @MrZak I just edited them in. Thanks for taking a look. $\endgroup$ – Dirly Dec 11 '17 at 22:59
  • 1
    $\begingroup$ Bake options seem to be correct. How do nodes you're baking from look like? I suppose there's some node setup created for the object you're baking from? (as you use Selected To Active). Make sure no material is overwriting baking ones in the Render Layers tab in the Properties editor. I couldn't reproduce that behaviour, can you create a strip down version of the project (e.g. small piece of the object which still shows that behaviour) and upload it blend-exchange.giantcowfilms.com $\endgroup$ – Mr Zak Dec 12 '17 at 0:01
  • $\begingroup$ @MrZak just included the blend file. I checked the renders layers tab everything looked normal but I've never really messed with that before so hopefully I didnt fat finger a shortcut to change something in there. $\endgroup$ – Dirly Dec 12 '17 at 2:25
  • 1
    $\begingroup$ So I just tried baking the textures from the the 3 separate objects onto the one combined object and it worked fine, with no color changes. I selected the 3 individual asteroids then the combined one and hit bake and it worked. Is that what you are trying to do? $\endgroup$ – Brenticus Dec 12 '17 at 2:46
  • 1
    $\begingroup$ It could be the spaceship that is causing the problem somehow, but I wouldn't know why. Are you able to upload a file with the asteroids and the spaceship? $\endgroup$ – Brenticus Dec 12 '17 at 2:50
1
$\begingroup$

So the reason being was the mirror modifier on the spaceship... caused a lighter tone. Not sure why but after I removed all mirror modifiers from the scene the color stayed the same. Thanks @Brenticus for suggesting an issue with the spaceship it lead to the fix!

Also: I was baking into an image with the wrong color space... Whenever you generate an image for an atlas its color space is sRGB by default. I switched it to raw and that worked like a charm. Leaving the above because somehow that did work one round.

$\endgroup$
  • $\begingroup$ Instead of adding two answers to your own question please use the edit link and make only one. $\endgroup$ – cegaton Jan 7 '18 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.