2
$\begingroup$

After I rendered all the JPEG and PNG images for my latest small project I followed my usual workflow in VSE and discovered the encoded video credits were of very poor quality. The credits are composed of RGBA PNG images while the main body of the animation are composed of JPEG iamges. After scratching my head a lot and comparing to completed projects with good quality credits I spotted I did not have RGB under output ticked on.

enter image description here

The rest of the animation did not seem to suffer without RGB on so I'd like to know why the credits benefited from it? I guess it has to do with the alpha channel of the PNGs.

Without RGB

enter image description here

With RGB

enter image description here

$\endgroup$
  • $\begingroup$ What was the setting before you chose RGB? I didn't think it was possible to have a null selection. $\endgroup$ – 3pointedit Dec 12 '17 at 1:12
  • $\begingroup$ Ahh, I see that when switching to ffmpeg output (for movie render) neither BW nor RGB is selected. But I could not return it to the null status. It looks like there is an alpha calculation being missed on the source image. Is there any chance that that this image is keyed? $\endgroup$ – 3pointedit Dec 12 '17 at 1:17
  • 2
    $\begingroup$ I will go and lodge a bug fault for the button I think. $\endgroup$ – 3pointedit Dec 12 '17 at 1:19
  • $\begingroup$ @3pointedit Good spot on selecting ffmpeg removes colour management. The only effect I had on the credits is a short fade out that you can see here video. Thanks for opening a bug fault. $\endgroup$ – chris loughnane Dec 12 '17 at 7:40
  • 1
    $\begingroup$ Follow up to my bug report, it turns out that it is an established setting, see developer.blender.org/T52988 however I believe that the ffmpeg preset to a hidden RGBA mode is a bug. $\endgroup$ – 3pointedit Dec 13 '17 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.