2
$\begingroup$

.blend file

I created a rig for my mesh. I created control bones, but they have influence on the mesh. How can I completly remove the influence from a bone to the mesh?

I selected every single control bone and set the weight to 0 and painted over the whole mesh, but there is still a influence as you can see in the picture.

enter image description here

$\endgroup$
  • $\begingroup$ Looking at the image you attached (and the file) it looks like the control bones aren't the only issue here. Some of the stretching looks like vertices that have no weights for any of the bones, which is why they are staying in place. $\endgroup$ – Brenticus Dec 11 '17 at 19:28
6
$\begingroup$

The easiest and most straight forward way is to uncheck Deform in bone properties (marked red on the image below). Second way is to delete from the mesh vertex groups named like the bones.enter image description here

$\endgroup$
  • 2
    $\begingroup$ The best way would be to do both things as it will guarantee no deformation issues or other weird bugs down the road. $\endgroup$ – Brenticus Dec 11 '17 at 17:46
4
$\begingroup$

You can remove (ie:clean, or reset to zero) a single bone's influence, you can use weight tools, like this:

enter image description here

edit: follow-up after a comment.

...imho it works 100%, but since moving that bone moves other connected bones (eg: thigh.L), which have weights are still infuencing the mesh... you see some influence, but from other bones.

enter image description here

This happen salso deactivating "deform" checkbox, as suggested by the other answer.

enter image description here

Deactivating "deform" checkbox keeps weight and thus, influence but it deactivates its evaluation (for that bone). Using clean you reset to zero the influence (useful maybe if you wish to start over painting it)

$\endgroup$
  • $\begingroup$ Does not work 100%, try it on shin.L and you will see. $\endgroup$ – Black Dec 13 '17 at 9:23
  • $\begingroup$ I added some content to explain why I feel it's working 100%. $\endgroup$ – m.ardito Dec 13 '17 at 12:36
  • $\begingroup$ Thank you very much for your effort! I had to set Limit (see first gif) to value 1 instead of 0.990 $\endgroup$ – Black Dec 14 '17 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.