I'm a beginner and can't seem to understand nor get rid of this shadow over the mesh... I'm guessing it has something to do with the faces behind the plane (extruded from an edge). No modifier besides mirror, and smooth shading is enabled.

mesh wireframe

It's my first modeling attempt, so I may have done a lot of things wrong. Any suggestions?

  • $\begingroup$ Remove those inner faces selected on the second screenshot, they won't be visible / useful but will provide shading artifacts and other problems with modifiers because they are non manifold geometry $\endgroup$ – Mr Zak Dec 9 '17 at 23:59
  • $\begingroup$ Didn't know about non manifold geometry, now I understand the issue. Thank you, Mr Zak! $\endgroup$ – Lawkie Dec 11 '17 at 0:10

What you are seeing aren't actually shadows. The dark area is caused due to an issue wit the normals of your mesh. The normals are the direction in which a face/edge/vertex is pointing, essentially which side is the outside and which side is the inside. The rest of your mesh is fine because blender can easily tell which section of the mesh is the inside and which is the outside. The reason for the dark area is because blender can't tell which section is facing out, since the front face is an exterior face, as well as the faces that are lying horizontal.

How you have the faces connected on the edge of where you have them highlighted isn't a good way to do it, since it can cause a lot of problems, one of them being the weird shading. You have a couple of options to fix it.

  1. As Mr Zak pointed out above, you could just delete them since they likely won't be visible in a render.

  2. Detach the outer edge of the selected area from the faces its connected to. TO do this, you will need to be in either vertex or edge select mode, and select the outer edge of what you currently have selected (not the middle ones where the mirror line is though). Then press V to rip the two edge loop apart.

I would think that the first option would be the way to go if you can get away with it.

  • $\begingroup$ Thank you very much for your answer! I tried to leave the horizontal faces in case they were visible from certain angles, but it seems that they bring more problems than anything in the final render. $\endgroup$ – Lawkie Dec 11 '17 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.