0
$\begingroup$

I'm trying to make R2D2 move along a path on a curve, but I'm having trouble making sure he conforms to the physics and shape of the path. As you can see in the screenshot, it's hard to make him adjust to the shape of the path without sinking into it or floating over it due to the height of the curve and the difficulty in matching it to the path's shape exactly.

enter image description here

EDIT:

This is what happens when I parent R2D2 to the empty in the .blend provided.

enter image description here

$\endgroup$
7
  • $\begingroup$ Duplicate one of the loops in the path and convert it from a mesh to a curve. You may also want toe have an Empty follow the path and Parent R2D2 to the Empty. $\endgroup$
    – Dontwalk
    Dec 7 '17 at 19:54
  • $\begingroup$ Hm when I did that and parented him to the curve, he ended up miles away from the curve for some reason. I also tried the follow path constraint with the curve as the target object, but he wouldn't move then. I'm not sure what I'm doing wrong. $\endgroup$
    – lakerice
    Dec 7 '17 at 20:35
  • $\begingroup$ @ - lakerice It has to do with Origins. Select your path and SHIFT + S > Cursor to selected. Then in Object Mode set Origin to Cursor. Add an Empty. Have the Empty follow the path and parent R2D2 to the Empty. $\endgroup$
    – Dontwalk
    Dec 7 '17 at 20:40
  • $\begingroup$ I tried that and unfortunately the empty went flying in another direction and definitely not following the path, just like R2 did. I tried Crtl+A scale and it still did it. Sorry if I'm not getting the instructions properly...I must be missing something obvious. $\endgroup$
    – lakerice
    Dec 7 '17 at 20:59
  • $\begingroup$ @ - lakerice Can you add your .blend file to your question using blend-exchange.giantcowfilms.com $\endgroup$
    – Dontwalk
    Dec 7 '17 at 21:10
1
$\begingroup$

Okay, here is what I did.

First I deleted the Rigid Body world and the curve you created and unused Empty's.

Then I selected your ground (and re-named it Ground). in Object Mode I applied Scale and Rotation press CTRL + A. In 'EDIT Mode' I selected the center Edge Loop and De-Selected the few vertices the fell over the edge of the road.

Then I duplicated the the selection 'SHIFT + D' and separated it from the mesh press "P" > Selection.

Then selected just the first vertex of what was the selection and pressed 'SHIFT + S' > Cursor to selection. Tabbed into Object mode and set the Origin to the 3d Cursor.

Then selected the new mesh that was duplicated earlier applied rotation and scale just out of habit. Tabbed into Edit Mode and Then selected just the first vertex of what was the selection and pressed 'SHIFT + S' > Cursor to selection. Tabbed into Object mode and set the Origin to the 3d Cursor. Next convert the mesh to a curve. I re-named it Curve.Path.

Then pressed SHIFT + C to send the cursor to the center. Next select The Ground mesh and the Curve.Path and press SHIFT + S > Selection to Cursor.

Now select just the Curve.Path and Tab int Edit Mode. select the first vertex and press "W" > Switch Direction to flip the Normals. Also, 'SHIFT + S' > Cursor to selection. Tab into Object Mode and de-Select everything.

Then add an Empty 'SHIFT + A' > Empty. Add an Object Constraint > Follow Path. Choose the Curve.Path as the Target.

Select the Curve.Path and in it's Data you can animate it's Evaluation Time.

EDIT:

Check off 'Follow Path' to have the empty stay perpendicular to the path. enter image description here

*I'm not sure all the steps here are necessary but I was being conservative and new it would work.

**This .blend contains only the Curve.Path and the Empty to keep it small. You can append them to your file if you choose and of course you'd need to parent R2D2 to the Empty.

$\endgroup$
6
  • $\begingroup$ Amazing! That totally worked. And thanks for the detailed instructions. One thing however, is that the empty moves perfectly straight along the line and as a consequence, R2D2 still hovers over the parts of my path that have dips and grooves. Is there a way to make the empty rotate on the X axis as it conforms to the shape of the path? $\endgroup$
    – lakerice
    Dec 9 '17 at 14:52
  • $\begingroup$ Try checking off some of the options in the Follow Path constraint like "Follow Curve". $\endgroup$
    – Dontwalk
    Dec 9 '17 at 14:59
  • $\begingroup$ Hm nothing seems to work...been trying other things too like duplicating the curve and offsetting it to have R2 follow 2 curves but that just made a huge mess. $\endgroup$
    – lakerice
    Dec 9 '17 at 16:04
  • $\begingroup$ See my EDIT to the answer. It works in my .blend file. $\endgroup$
    – Dontwalk
    Dec 9 '17 at 20:33
  • $\begingroup$ I've posted what happens when I try to parent to your empty. Even with the settings you provided, he still hovers over completely parallel to the x axis. Sorry if I'm still missing something. $\endgroup$
    – lakerice
    Dec 9 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.