0
$\begingroup$

I'm attempting to merge these two meshes together. They are already right beside each other in the way that I want to merge them.

enter image description here

The top mesh, highlighted in orange, and the bottom mesh, which is a flattened cube that I've curved using a path (the black line on the right)

I'm trying to follow this question and answer to join the two meshes but I can't get past the first step of selecting both of them at one time - is this because of the curve?

Thanks,

P.S. Here's the .blend

$\endgroup$
3
$\begingroup$

When joining [⎈ CtrlJ] objects, the new object will have the modifier stack of the active object.

If you (e.g.) select the mesh with the modifier and then the mesh without, the last selected becomes the active object (in this case the mesh without the modifier). When joining them, the new object will have no modifier and the mesh part which needs the modifier will be wrong.

The solution is to apply the modifier first by selecting the mesh and pressing apply on the modifier.

enter image description here

(legoparrot beat me, still going to leave the answer since there are some more details)

$\endgroup$
  • $\begingroup$ I applied the modifier but still can't select the other model $\endgroup$ – Katana24 Dec 7 '17 at 12:29
  • $\begingroup$ I actually had to use the "Border Select" tool to select both before joining $\endgroup$ – Katana24 Dec 7 '17 at 12:35
  • 1
    $\begingroup$ @Katana24 I could select the object just fine in your file. Try temporarily reseting your settings to check if you have messed up some operation? $\endgroup$ – Leander Dec 7 '17 at 12:54
1
$\begingroup$

Apply the curve modifier. Then select both > control+J. Then go File > Export > Wavefront(.obj), and select the file location and click Export OBJ.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.