2
$\begingroup$

I am trying to install blender 2.79 on ubuntu 17.10. Downloaded blender-2.79-linux-glibc219-x86_64.tar.bz2 from

https://www.blender.org/download/

ran the command: sudo tar xvjf blender-2.79-linux-glibc219-x86_64.tar.bz2

changed directories to the blender executable and ran the command: ./blender

Got this error:

./blender: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

If I run /sbin/ldconfig -p I get the line: libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1

So I'm guessing I need to link to it somehow? I tried
sudo ln -s /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib which didn't work, and maybe I've made things worse.

Any help would be appreciated.

$\endgroup$
  • $\begingroup$ I just noticed I need libGLU.so.1 not libGL.so.1. So I'm missing a library I need to install? $\endgroup$ – dennis Dec 6 '17 at 23:15
3
$\begingroup$

I had the same issue. Running the libglu1 installation addressed this. I'm running Blender 2.79 on Ubuntu 16.04

sudo apt-get install libglu1
| improve this answer | |
$\endgroup$
1
$\begingroup$

used lubuntu's synaptic package manager to install libglu1-mesa and now everything works.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.