2
$\begingroup$

With the new Denoiser function, we're finally able to drastically reduce the samples in our scene without having to worry about the noise to much.

I'm rendering my scene with less samples now (500 are okay), and because the renderings take so long, I doesn't composite the rendering directly. Instead, I have an OpenEXR output node set to .png allowing me to export all passes as single files for further compositing, so I'm able to tweak things without having to rerender everything again.

enter image description here

But with Denoiser enabled, my "Image" pass will denoise just fine, but all other passes are simply ignored. That means that most of the other passes (like AO, DiffDir, DiffInd...) are pretty noisy now and doesn't really work in composition well. How do I enable Denoising for all of those passes too? I'm aware of this will take about four to five minutes longer per frame, but that's fine as long as my passes aren't noisy anymore.

Any way to enable denoising for all passes without having to rerender eversthing again and again?

$\endgroup$
3
$\begingroup$

You might not be able to use Denoiser feature since it is done on the render itself as it goes, using 3d data. You could use the Bilateral Blur technique outlined by Bartek Skorupa and used here on a node group I used when helping with Theory Animation. You could then correct only those passes that have the problem with the noise.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.