3
$\begingroup$

I started following this tutorial from Blender Guru to do a rainy scene. While most of it works, he's using Blender Render, and by the end the process of setting up the dynamic paint just doesn't work the same way in Cycles. Specifically, after this moment (21:24), the process changes completely, as Cycles Render uses nodes, while the Blender Render does not. Anyone can assist me in setting this up for Cycles, taking into account that all my materials are using the new Principled shader?

I have tried using the baked image sequence as the factor for a mixed shader but have gotten no results. The material remains the same after plugging it in.

Node setup

Further screencaps, I got it to try to work for one frame, I don't even know how, and I should've screencapped it, but some more as proof that this is not working.

I don't even know

Notice how that's supposed to be frame 46, have a look at the mask for frame 46.

It's pretty dark.

This should be very much mixed down to the other half.

$\endgroup$
  • 2
    $\begingroup$ If it is just about how to use the result image sequence, then add the image sequence as a node into the material and use it to split the mix of the principled shader and another shader to get your result, or use it directly to input the amount of gloss shader, etc. Show us a screens hot of what you have so far and we can try to help you figure out how to plug it in. $\endgroup$ – Craig D Jones Dec 5 '17 at 19:50
  • $\begingroup$ @CraigDJones I tried out what you suggested, have a look at the lack of results. It won't even actually work as a mask to mix the shaders. $\endgroup$ – Vitoria90 Dec 6 '17 at 15:13
  • 1
    $\begingroup$ It looks to me like your result is too dark, and that means there is something wrong in your dynamic paint setup prior to getting this far. You should have much higher contrast there to get white areas in a black map that shows where the materials will split. To test, go to a simple cube scene and try working out the settings to get a simple 30 frames sequence that has the high contrast you are looking for. Work that out, and then you can rework the dynamic paint for the complex scene. $\endgroup$ – Craig D Jones Dec 6 '17 at 16:22
  • 1
    $\begingroup$ Have you actually rendered several consecutive frames, or are you just looking at the rendered preview in the viewport? For the images to update in the viewport, you need to enable Auto Refresh. That shouldn't be needed for a final render. $\endgroup$ – Duane Dibbley Dec 6 '17 at 16:22
  • 1
    $\begingroup$ @DuaneDibbley - Damn, it was that and I had to put the alpha into the factor. You should post that as an answer so I can mark it as correct in case someone else has the same issue. $\endgroup$ – Vitoria90 Dec 6 '17 at 17:09
1
$\begingroup$

To get the frames to update when previewing in the 3D viewport, you need to enable Auto Refresh on the image texture. In final render, this is not needed.

enter image description here

This is not documented in the online manual's section on the Image Texture node, and the only references I've found to it are on the various help sites for Blender. Therefore I can't say for sure why this is so, but I'm assuming that in the 3D viewport speed is given priority over accuracy, while renders give priority to accuracy over speed.

In this answer to a related question, it is mentioned by Ray Mairlot. I've seen this mentioned in other places as well, but this was the first one a quick search turned up.

You may also want to try using the Alpha socket of the image texture as input for the Fac socket of the mix node, though that will depend on how the dynamic paint was set up.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.