0
$\begingroup$

Is there a way to use the paint tool on a .dae file. I am trying to do a custom camouflage on a plane, but the model doesn't let me texture paint on it? Please help. enter image description here

enter image description here

$\endgroup$
  • 4
    $\begingroup$ once it's imported, it's a blender model... please describe (or show) what you do to paint texture on your model, so to spot what is wrong. $\endgroup$ – m.ardito Dec 5 '17 at 9:53
  • 2
    $\begingroup$ If the model doesn't let you texture paint on it, ask him nicely, maybe he will change his mind. $\endgroup$ – Mzidare Dec 5 '17 at 10:13
  • 1
    $\begingroup$ @Mzidare This comment helps no one and is rude. Please read the "Be nice" policy blender.stackexchange.com/help/be-nice $\endgroup$ – Reaper Dec 5 '17 at 12:03
  • 1
    $\begingroup$ @Reaper for the record I did not find that comment rude, or anything in the Be nice policy that comment violates. The policy even says "bring your sense of humor." $\endgroup$ – David Dec 5 '17 at 13:09
  • $\begingroup$ If you have the engine set to Blender Render, then you should be able to select the object and switch to Texture Paint mode. In the Slots tab in the tool bar, do you see an available slot to paint on? If not, can you show us a screen shot of what you do see, including the material and texture settings in the Properties editor? $\endgroup$ – Craig D Jones Dec 5 '17 at 17:55
2
$\begingroup$

There are a couple of steps that can be taken to find the problem, as well as make the painting work easier.

  1. Ensure you have the mesh you want to paint on selected. From the screenshots above it appears the plane is made of a number of different objects. You will need to have only the main fuselage/wind object selected to be able to paint on it. In the second screenshot, you have all of the objects selected. Texture paint will only apply to the active object (the last selected one) so you can't paint on a group of objects at the same time. It will also be helpful to isolate the object you are painting on in the view (although this may be personal preference) which you can do with the / key on the numberpad or with Shift+H. This will make it easier to see what you are painting, as well as lighten the load on the viewport in the case of slow painting.

  2. Make sure the object has a UV map. It looks like you tried to add UVs to your object, but since they are all selected, you may want to ensure that the main mesh has a UV map suitable for painting. If you open the UV image editor with the main object selected and in edit mode, you will be able to tell if the plane has been unwrapped properly.

  3. It appears that the plane already has a texture applied, so it would probably be best to add another paint slot or another texture so that you don't permanently damage the textures that are there already.

As mentioned above in the comments, once a file is imported it becomes the same as any other blender object/file. Therefore all standard blender procedures will work with your object.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.