4
$\begingroup$

I have an image linked, and I have the right brush selected, but I still can't paint on the object. I tried on another image on the same object just to test and it worked, so I tried deleting and making a new image but it still doesn't work.

Screenshot

While I'm at it I might as well knock two birds with one stone. With the head I'm working on all the hair particles I have added shows up ridiculously bright and really shiny every time I go to render, which is strange because I was following a tutorial and theirs seemed perfectly fine.

Render

$\endgroup$
4
  • 2
    $\begingroup$ According to the rules of this site knocking two birds at the same time is discouraged, asking separate question is what you're expected to do. As to your first question try either selecting all faces of the mesh or disabling Face Selection Masking in the 3d viewport header. Related blender.stackexchange.com/questions/14215/… (it's for weight paint but the procedure is the same) $\endgroup$
    – Mr Zak
    Commented Dec 5, 2017 at 19:39
  • $\begingroup$ What kind of shader are you using for the hair? $\endgroup$
    – Millard
    Commented Aug 11, 2019 at 13:11
  • $\begingroup$ when that happens to me, I delete the texture of the material and the brush is enabled again... $\endgroup$
    – Adèle
    Commented Nov 20, 2020 at 9:04
  • $\begingroup$ Try to Remesh by going to Remesh > Remesh. $\endgroup$ Commented May 16, 2022 at 17:07

4 Answers 4

2
$\begingroup$

Make sure that you have a texture that is not plane black as this acts as a mask. In the textures section use blend and select the circular shape that is white.

$\endgroup$
1
$\begingroup$

Just disable the Backface Culling in the texture painting mode.

backface culling

$\endgroup$
1
  • $\begingroup$ Thanks! This really helped, not clear how this might be logically linked to brush effects.. ;-) $\endgroup$ Commented Aug 12, 2022 at 10:09
1
$\begingroup$

Go into edit mode, select all, and then press Ctrl+N to correct your normals. Then try painting and see the paint show up.

$\endgroup$
2
  • $\begingroup$ tried it didnt work $\endgroup$ Commented Dec 7, 2017 at 0:24
  • 1
    $\begingroup$ Maybe try removing the brush texture- you have the black image set as your brush as well as your target. $\endgroup$ Commented Dec 7, 2017 at 0:52
0
$\begingroup$

Texture painting wouldn’t work in these cases:

  • The wrong object is selected. You can switch to the object you want by hovering over it and pressing Alt + Q

  • You have no texture or the wrong texture set in the texture slot (Texture Slots dropdown menu in the header – Do not confuse with Texture which concerns the brush texture)

  • If the brush has a black texture (it does nothing). Make sure that you don’t have a black texture set to the brush (in the header or under Brush settings).

  • If the Brush is not selected

  • If the brush has a Blend mode that wouldn’t show (make sure it’s set to Mix)

  • If normal are flipped and Backface Culling is turned on under options in the header. Check this by activating Face orientation in the overlays menu. It’s preferable to go in Edit mode and flip the normal.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .