2
$\begingroup$

I am trying to make an object that has a hole. I used the boolean modifier with a cylinder selected. But the circle around the object does not look right.

I have the smooth shader turned on and a subdivision of 2 views.

Am I doing something wrong?

Can someone show me what I'm doing wrong or a better way of doing it?

Thank you in advance.

Boolean Object

This is what it looks like with no subdivisions.

But now I cant add a smooth shader or a sub divider to it. Is that just what will have to look like? No Subdivisions

This is what I was able to get with no smooth shader.

Done

Once I do smooth Shader.

With smooth

$\endgroup$
  • $\begingroup$ "used the boolean modifier with a cylinder selected" the problem is since then. Either retopo the mesh (construct new one with the same forms atop of this one but with cleaner geometry) or undo results by boolean. When subsurfing all tiny long quads, ngons and tris become visible $\endgroup$ – Mr Zak Dec 4 '17 at 19:05
  • $\begingroup$ I find that the Boolean Modifier works best if it is the only modifier when it is applied. Also, apply Scale to both objects (one at a time) in Object Mode. $\endgroup$ – Dontwalk Dec 4 '17 at 19:11
4
$\begingroup$

Topology overview:

desc

You will probably want to go with similar topology for Smooth Shading and Subdivision Surface modifer.

It's created from simple Circle.

  1. Extruded and Scaled outwards.
  2. Extruded bottom edge.

    Tip: To streighten Edge Loop on the Z axis - press S > Z > 0

  3. Whole shape extruded.
  4. Bottom part extruded.

After this you will need to add Proximity Loop to have nice Bevel with Bevel Modifier.

modifiers

You can control edge sharpness with Bevel Width and number of Segments.

Blend file:

$\endgroup$
2
$\begingroup$

It looks like your boolean modifier is before your subsurf modifier. Boolean modifiers create a bunch of nasty triangles or n-gons that do not subdivide well. If you move the boolean to after the subsurf it will have nicer edges, although the shading will be bad probably. If you then enable auto-smooth normals in the object properties panel it should look much better.

$\endgroup$
  • $\begingroup$ I added updated image with extra comments. $\endgroup$ – user138568 Dec 4 '17 at 20:25
  • $\begingroup$ If you subdivide the cylinder you can make it a lot smoother. As far as I know smooth shading doesn't apply to the mesh generated by the boolean. $\endgroup$ – Brenticus Dec 4 '17 at 21:41
  • $\begingroup$ I added more pictures, once without the smooth shading, and then the other with. Is this normal? I tried normalizing and it still didn't do anything. $\endgroup$ – user138568 Dec 4 '17 at 21:49
  • $\begingroup$ Try enabling Auto Smooth in the normals section of the Object properties panel (the tab with the 3 vertex triangle). $\endgroup$ – Brenticus Dec 4 '17 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.