1
$\begingroup$

Does anyone know why this is happening? Render view shows the material, while the final render does not, and it is only one material (black plastic renders a standard while clay).Render Preview in Viewport Final Render

$\endgroup$
  • 1
    $\begingroup$ Can you add a screenshot of your materials tab and/or compositing tree? $\endgroup$ – Brenticus Dec 4 '17 at 7:04
  • $\begingroup$ It looks like the normals on your object are inverted. Try recalculating them in edit mode with Ctrl N and see if that does anything. I can't imagine it would though. Other thing to check is if there is a material in the Material Override slot in the Render Layers tab. $\endgroup$ – Brenticus Dec 4 '17 at 19:57
  • $\begingroup$ They did need to be recalculated but it still didn't change the final render. Normals Reset + Render $\endgroup$ – Benjamin Winchester Dec 4 '17 at 20:13
  • $\begingroup$ Did you check the render Layers tab to see if there was a Material in the Override slot? $\endgroup$ – Brenticus Dec 4 '17 at 20:37
0
$\begingroup$

Solved.

A couple of the node settings were set way too high and applying the effect over too great an area making it appear as though there was a white material over the whole thing.

Thanks for the help.

$\endgroup$
-1
$\begingroup$

Check your material window again, under the selection area, make sure it is set to Data, not Object.

object

data

thats about all I can help without the file :) hope it works!

$\endgroup$
  • 1
    $\begingroup$ In his post he says that it shows correctly in the rendered view, while your suggestion causes rendered view to not show the material. $\endgroup$ – Brenticus Dec 4 '17 at 6:55
  • $\begingroup$ Hence my request for the file??? I attempted to provide as much a description as I could without proper information. $\endgroup$ – Avieasolia Leader of Solia Dec 4 '17 at 19:22
  • $\begingroup$ From the question though it is clear that your solution won't work. If you want to request a file it's better to add a comment to the question with such a request. $\endgroup$ – Brenticus Dec 4 '17 at 19:26
  • $\begingroup$ Screenshots posted in response to Brenticus' original answer $\endgroup$ – Benjamin Winchester Dec 4 '17 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.