1
$\begingroup$

I am trying to simulate accurately the merging of colors when a color wheel rotates quickly.

enter image description here

This color wheel rotates 1980º on the Z between frame 1 and frame 40.

However when I export the animation, the colors are not blending:

enter image description here

We can see that the motion of the plane is, however, blurred (blurry areas outside the color wheel).

I have tweaked different settings in the Motion Blur tab of the Render panel, without success.

I would love a solution that is as physically accurate as possible.

$\endgroup$
  • $\begingroup$ Motion blur blurs geometry movement. Maybe propellor like blades of solid colour that were spinning. But then wouldn't it just give the gradient you have? $\endgroup$ – sambler Dec 2 '17 at 8:33
  • $\begingroup$ @sambler a colored disc that spins will see its colors blend (I had assumed it was a motion blur generating this effect), you can make the experiment at home with a spinning top or check out this video: youtube.com/watch?v=Ala7813u3Zg $\endgroup$ – MicroMachine Dec 2 '17 at 8:54
  • $\begingroup$ That is a disc of solid colours, not a texture of colour gradient spinning. Make mesh blades with a single colour on each and spin them. $\endgroup$ – sambler Dec 2 '17 at 8:58
2
$\begingroup$

I've re-created a similar situation and this appears to be working fine.

Here's the image I have used to rotate :

color wheel

It is essentially just a screen grab from the Gimp colour picker. I chose this in preference to your example due to it having more features (such as the triangular pointer in the middle) to make the effect more noticeable.

Keyframing rotation for 3600 degrees over 100 frames (a similar rate to your example) and setting Motion Blur shutter length to 2.00 frames produces the following result :

motion blur result

Turning the speed up even higher (36000 over 100 frames) results in almost complete merging of the colors as you would expect in the 'real' world :

extreme motion blur

Looking at your example file, I think your blur just isn't extreme enough to be noticeable. I increased the motion blur frames to 2.0 (from 0.5 in your example) and increased the rotation speed by a factor of 10 and got the following result :

spin motion blur

$\endgroup$
  • $\begingroup$ Thanks for your solution, increasing the speed definitely worked out. In the exported animation frames, some frames show the disc less blurry than others, do you know what might be causing that? like here I feel the blur should be consistent, maybe I'm wrong $\endgroup$ – MicroMachine Dec 6 '17 at 17:38
  • $\begingroup$ You’re welcome - glad to help. In the real world the blur would be consistent but Blender has to approximate the blurring. I beieve Blender produces the blur by sampling a number of sub-frames before and after the frame being rendered and combining the results. I believe the effect you’re seeing is where the speed of rotation is causing an interference effect as it is close to a number of full rotations in the gap between subframes. The problem should be lessened by increasing the number of samples used for the blurring - although, unfortunately, I don’t think Blender provides such an option. $\endgroup$ – Rich Sedman Dec 6 '17 at 22:56
  • 1
    $\begingroup$ I thought it had to do with shutter speed, as when a camera films wheels of a slowing car and the wheel seems to be spinning the other way for a second... Or if you look at a spinning object and blink, it'll look still $\endgroup$ – MicroMachine Dec 6 '17 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.