7
$\begingroup$

I'm working on some models someone else made as part of a project. The .blend files they've given me have several objects that get no selection outline in the viewport despite Outline Selected being checked. Other objects work normally. I assume there must be something else that can cause an object to not be outlined, on a per object basis.

Can anyone tell me what this might be? I cannot find any differences between the settings of objects that do and don't have selection outlines.

$\endgroup$
4
  • $\begingroup$ plz attach screenshot of outliner or attach the file $\endgroup$
    – atek
    Nov 28 '17 at 8:23
  • $\begingroup$ Sounds like a bug to me. Did you tried appending all objects into a fresh file? $\endgroup$
    – brockmann
    Nov 28 '17 at 11:38
  • 1
    $\begingroup$ have you tried to select them and then move them? If it doesn't work, their selection is restricted. Go to the outliner (right top corner on the default screen) and search for your objects. On the right side there will be an eye, a cursor, and a camera. Clicking on the cursor will toggle if the object can be selected. $\endgroup$
    – Teck-freak
    Nov 28 '17 at 12:02
  • $\begingroup$ Cannot attach the file as it's the property of the client. Appending to new file doesn't fix it. I can move and interact with the objects normally. $\endgroup$
    – Ascalon
    Nov 28 '17 at 19:44

14 Answers 14

2
$\begingroup$

I had the same problem for a few days.

After searching for a solution online without result, I simply just randomly clicked here and there... – and found the solution that worked for me. That is:

  1. Select the object (which has the problem with a missing outline).
  2. Change it to sculpt mode.
  3. Change it back to object mode. And the outline appears again!

I still don't understand why. :)

$\endgroup$
3
  • 2
    $\begingroup$ I have this same problem, but the fix above doesn't solve it. Seems mysterious. $\endgroup$
    – Stabledog
    Jan 19 '19 at 14:00
  • $\begingroup$ Toggling doesn´t work. Was appointed previously. Down voted. $\endgroup$ Mar 12 '19 at 15:36
  • $\begingroup$ There are lots of answers being given to this question because there are lots of causes. I've marked this as correct because this was the problem that caused me to ask the question in the first place. $\endgroup$
    – Ascalon
    Mar 19 '19 at 0:02
11
$\begingroup$

I went around and around with this for a bit today and the solution for me was to click the button to the left of the 'Overlays' pulldown. The tooltip reads "Display overlays like gizmos and outlines". This did the trick.

Seems like a silly place to bury the toggle for that functionality, but what do I know.

$\endgroup$
1
  • 3
    $\begingroup$ If anybody is referring to Blender 2.8, this solves the problem. $\endgroup$
    – cigar_matt
    Apr 16 '19 at 21:56
9
$\begingroup$

For the people who are having the same problem in blender 2.80, make sure to enable show overlays on the top right corner of the viewport (it is the icon with two circles). For some reason blender hides the highlights along with the cameras and lights upon disabling it. Hope this helps!

$\endgroup$
2
  • $\begingroup$ I'm using 2.90.0 and had the same problem. I wonder if this would have solved the problem, except I already tried something else that fixed it. $\endgroup$
    – DarenW
    Nov 10 '20 at 21:59
  • $\begingroup$ Thank you! This works in 2.90 too! I would have reinstalled Blender. (which also would've worked) $\endgroup$
    – Clobro
    Apr 7 at 22:27
3
$\begingroup$

enter image description here

Press "N" keyboard key. Go to DISPLAY: uncheck "ONLY RENDER". You should have your selected object outline back again.

$\endgroup$
2
$\begingroup$

Having found myself in the same predicament inadvertently I was a bit frustrated as you get so used to seeing the outline of the object you are manipulating. I found though in my case it was a case of ticking the 'Only Render' box in the display settings! I guess there may be other circumstances in the display and setup settings which could cause the outline of the selected object to be not visible.

$\endgroup$
2
  • $\begingroup$ yet, it is another one who gets the result for the "correct" answer. Okay, I am seeing some biased manipulation here.... Thanks anyways to those who truly know the correct answer was mine. $\endgroup$ Mar 12 '19 at 15:35
  • 1
    $\begingroup$ Its no big deal really I think. I answered the question on 31 jan and from what I can see you answered this 2 days ago. I'm not after points or anything, just trying to help where I can with what I know. $\endgroup$
    – Tonzodehoo
    Mar 14 '19 at 12:20
1
$\begingroup$

I encountered the issue recently in Blender 2.8:

I found out, that the issue only appeared in Layout mode and it seemed like the workspace was somehow broken.

I simply added a new Layout Workspace ("+" at the right top navigation >> "General" >> "Layout") and deleted the broken one.

$\endgroup$
0
$\begingroup$

I had this problem and found that the object I was trying to select was the parent object for several others, and I suspect that some of that tree of relationships included objects which were not selectable in the scene browser.

I decided that I didn't like having the target object be a parent anyway, so severing those child relationships solved the problem. It seems like Blender was deciding "if you try to select an object and some of its children aren't selectable, don't light up the parent."

$\endgroup$
0
$\begingroup$

Which Blender version are you using? Apparently this is an ongoing bug happening since 2014. Someone reported it before, but was archived as more user informations was required:

https://developer.blender.org/T42276

I've downloaded the .blend file in the bug reporting thread and I think is fixed in version Blender 2.8, but maybe you can try with your problematic files and if the bug is still there try to provide the required information to the developers to finally fix it.

$\endgroup$
0
$\begingroup$

In the top right corner of the screen click the Show Overlays option to resolve this problem in Blender 2.8

$\endgroup$
1
  • 1
    $\begingroup$ This answer has already been posted. $\endgroup$
    – Clobro
    Apr 7 at 22:28
0
$\begingroup$

Blender 2.8: you might have disabled selection (arrow icon)

go to top right "Filter" icon -> make sure second arrow "Selectable" icon is pressed -> enable arrow icon for your object

$\endgroup$
0
$\begingroup$

In blender 2.8: I fixed it by clicking (show overlays) viewport overlays, And check box wireframe (under geometry). The object outline showed up again.

$\endgroup$
1
  • 1
    $\begingroup$ This solution has already been posted. $\endgroup$
    – Clobro
    Apr 7 at 22:29
0
$\begingroup$

There are apparently many ways this can happen, but if you are a new user make sure you are not on the "layout" tab on the top, you need to be on the "Modeling" tab.

I had the same problem where it appeared that nothing would outline, but it was from me inadvertently being in the wrong tab.

$\endgroup$
0
$\begingroup$

Minutes ago, I had this problem in 2.90.0. I had four 3D Viewpoint tiles up. Three smaller ones worked fine, while the big one didn't show the outline. Solved it by breaking the big one into three, joining the original three over the new three, breaking these each into two, then joining those new ones - hard to describe, but basically tile gymnastics such that the original malfunctioning tile is gone and a new one is created. Just don't break the original one into two and rejoin - that does nothing.

After seeing the answer by frosty Warlock, I wonder if by default new 3D Viewports have that button on by default, and in my original malfunctioning viewport it was off and I didn't notice.

$\endgroup$
0
$\begingroup$

Now in blender 2.92 is in the shading menuenter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.